"Service engine soon" light on even after new O2 censors?

Asked by Jun 05, 2017 at 05:15 PM about the 1996 Chevrolet S-10 2 Dr LS Standard Cab LB

Question type: Maintenance & Repair

Yep, it will go off for a few days at a time...
anybody else ever see this problem?
It almost seems like a switch/short in the electrical harness

(4.3 L)

1 Answer

I have replaced the sensors, replaced the rotted out filler neck and cap, replaced the rotted out sending unit in the tank... the light still came on, especially when the fuel level got down around 1/2 tank.... until I had my automatic trans flushed. Now the light stays off. Weird, I know, but that's what worked for me. (2.2L, 170K miles).

Your Answer

Chevrolet S-10 Experts

  • #1
    Andrew Olsen
    Reputation
    2,560
  • #2
    John Saffrahn
    Reputation
    1,050
  • #3
    Trebor66
    Reputation
    1,040
View All

Related Models For Sale

Used Ford Ranger
197 Great Deals out of 5,575 listings starting at $995
Used Toyota Tacoma
724 Great Deals out of 45,871 listings starting at $2,500
Used GMC Sonoma
4 Great Deals out of 428 listings starting at $2,150
Used Ford F-150
3,297 Great Deals out of 224,483 listings starting at $1,200
Used Dodge Dakota
86 Great Deals out of 3,625 listings starting at $1,499
Used Chevrolet Blazer
7 Great Deals out of 922 listings starting at $950
Used GMC Sierra 1500
1,226 Great Deals out of 64,898 listings starting at $999
Used Dodge Ram 1500
413 Great Deals out of 11,096 listings starting at $1,500
Used Chevrolet C/K 1500
815 listings starting at $2,436
Used Chevrolet Camaro
444 Great Deals out of 31,892 listings starting at $1,450
Used Ford Mustang
599 Great Deals out of 39,962 listings starting at $1,895

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.