"Service engine soon" light on even after new O2 censors?

Asked by Jun 05, 2017 at 05:15 PM about the 1996 Chevrolet S-10 LS LB RWD

Question type: Maintenance & Repair

Yep, it will go off for a few days at a time...
anybody else ever see this problem?
It almost seems like a switch/short in the electrical harness

(4.3 L)

1 Answer

I have replaced the sensors, replaced the rotted out filler neck and cap, replaced the rotted out sending unit in the tank... the light still came on, especially when the fuel level got down around 1/2 tank.... until I had my automatic trans flushed. Now the light stays off. Weird, I know, but that's what worked for me. (2.2L, 170K miles).

Your Answer:

Chevrolet S-10 Experts

  • #1
    Andrew Olsen
    Reputation
    2,870
  • #2
    Trebor66
    Reputation
    1,150
  • #3
    Js08016
    Reputation
    1,120
View All

Related Models For Sale

Used Ford Ranger
114 Great Deals out of 4,196 listings starting at $995
Used Toyota Tacoma
457 Great Deals out of 49,501 listings starting at $2,900
Used GMC Sonoma
285 listings starting at $2,900
Used Ford F-150
2,235 Great Deals out of 188,247 listings starting at $1,200
Used Dodge Dakota
87 Great Deals out of 3,007 listings starting at $1,200
Used Chevrolet Blazer
748 listings starting at $900
Used GMC Sierra 1500
658 Great Deals out of 56,581 listings starting at $888
Used Dodge Ram 1500
318 Great Deals out of 8,827 listings starting at $2,495
Used Chevrolet C/K 1500
727 listings starting at $2,200
Used Chevrolet Camaro
285 Great Deals out of 26,671 listings starting at $2,700

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.