My 96 S10 has a tail light and backup light problem all other lights work. Why do the tail lights and backup lights not?

Asked by Mar 17, 2013 at 05:13 PM about the 1996 Chevrolet S-10 2 Dr LS Standard Cab LB

Question type: Maintenance & Repair

2 Answers

10

has a bad ground check your tellights ground an it shoud fix your problem i have oned 4 an have had the same problem

1 out of 1 people think this is helpful.
96,135

They are on separate circuits so it can't be a bad fuse. They might use the some ground connection. If the running lights are out in the front, check the fuse. The reverse lights have a different fuse and there is a switch on the transmission. -- I would check for power at the back with a meter. If there is power, check the resistance to ground. If there is no ground connection, run a new ground wire to the metal body.

1 out of 1 people think this is helpful.

Your Answer

Add photo

Related Questions

Search Chevrolet S-10 Questions

Chevrolet S-10 Experts

#1 Andrew Olsen
Andrew Olsen
Reputation 2,240
#2 John Saffrahn
John Saffrahn
Reputation 970
#3 Trebor66
Trebor66
Reputation 950
View All

Related Models For Sale

Used Ford Ranger
192 Great Deals out of 5,979 listings starting at $1,299
Used GMC Sonoma
8 Great Deals out of 489 listings starting at $2,995
Used Toyota Tacoma
501 Great Deals out of 38,892 listings starting at $2,900
Used Ford F-150
2,214 Great Deals out of 208,668 listings starting at $1,499
Used Dodge Dakota
110 Great Deals out of 3,829 listings starting at $1,199
Used Chevrolet Blazer
1,148 listings starting at $1,299
Used Dodge Ram 1500
441 Great Deals out of 11,296 listings starting at $1,000
Used GMC Sierra 1500
819 Great Deals out of 66,147 listings starting at $1,995
Used Chevrolet C/K 1500
906 listings starting at $2,500
Used Chevrolet Camaro
153 Great Deals out of 32,674 listings starting at $1,995
Used Ford Mustang
362 Great Deals out of 46,831 listings starting at $1,999