My 96 S10 has a tail light and backup light problem all other lights work. Why do the tail lights and backup lights not?

Asked by Mar 17, 2013 at 05:13 PM about the 1996 Chevrolet S-10 2 Dr LS Standard Cab LB

Question type: Maintenance & Repair

2 Answers

10

has a bad ground check your tellights ground an it shoud fix your problem i have oned 4 an have had the same problem

1 of 1 people found this helpful.
104,745

They are on separate circuits so it can't be a bad fuse. They might use the some ground connection. If the running lights are out in the front, check the fuse. The reverse lights have a different fuse and there is a switch on the transmission. -- I would check for power at the back with a meter. If there is power, check the resistance to ground. If there is no ground connection, run a new ground wire to the metal body.

1 of 1 people found this helpful.

Your Answer

Chevrolet S-10 Experts

  • #1
    Andrew Olsen
    Reputation
    2,660
  • #2
    John Saffrahn
    Reputation
    1,090
  • #3
    Trebor66
    Reputation
    1,070
View All

Related Models For Sale

Used Ford Ranger
126 Great Deals out of 4,992 listings starting at $1,299
Used Toyota Tacoma
540 Great Deals out of 41,034 listings starting at $2,500
Used GMC Sonoma
363 listings starting at $2,150
Used Ford F-150
3,016 Great Deals out of 229,524 listings starting at $1,300
Used GMC Sierra 1500
1,106 Great Deals out of 61,544 listings starting at $1,295
Used Dodge Dakota
81 Great Deals out of 3,427 listings starting at $1,475
Used Chevrolet Blazer
6 Great Deals out of 842 listings starting at $950
Used Dodge Ram 1500
324 Great Deals out of 10,666 listings starting at $1,988
Used Chevrolet Camaro
385 Great Deals out of 31,367 listings starting at $3,495
Used Chevrolet C/K 1500
818 listings starting at $2,600

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.