My 1996 Chevy S10, 4.3 V6 cranks but has no fire to spark plugs, please help

Asked by Aug 05, 2009 at 05:00 PM about the 1996 Chevrolet S-10 LS Extended Cab 4WD

Question type: Maintenance & Repair

1 Answer

35

i would start by checking that your rotor in the distributor is not worn out but also check and make sure your ckp sensor is giving a signal

3 people found this helpful.

Your Answer:

Chevrolet S-10 Experts

  • #1
    Andrew Olsen
    Reputation
    2,830
  • #2
    John Saffrahn
    Reputation
    1,120
  • #3
    Trebor66
    Reputation
    1,110
View All

Related Models For Sale

Used Ford Ranger
104 Great Deals out of 4,208 listings starting at $1,700
Used Toyota Tacoma
429 Great Deals out of 49,112 listings starting at $2,400
Used GMC Sonoma
3 Great Deals out of 290 listings starting at $2,150
Used Ford F-150
2,319 Great Deals out of 198,938 listings starting at $1,300
Used Chevrolet Blazer
5 Great Deals out of 729 listings starting at $900
Used Dodge Dakota
80 Great Deals out of 3,028 listings starting at $1,000
Used GMC Sierra 1500
804 Great Deals out of 60,078 listings starting at $1,495
Used Dodge Ram 1500
346 Great Deals out of 9,243 listings starting at $1,800
Used Chevrolet C/K 1500
704 listings starting at $800
Used Chevrolet Camaro
242 Great Deals out of 26,934 listings starting at $2,900

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.