1996 S-10 4.3 modified vortec V-6 no start after warm up

Asked by May 02, 2014 at 11:04 AM about the 1996 Chevrolet S-10 2 Dr LS Extended Cab SB

Question type: Maintenance & Repair

Oops My little road racer has developed that has me puzzled. I've replaced everything on top of the engine as I built it over the last two years. Last week the kid borrowed it and brought it home on empty, Duhh I later took it to the same station I've used for 10 years and fueled it up, fueled it to the top and packed in as much as I could in anticipation for a road trip. I went inside for a cold beverage and when I came back and tried to restart it started right up as usual but then kind of shuddered, idle dropped off and it died. I just kind of figured I was lucky and hadn't run out of gas before I got to the pump. I cranked it over a few times and no start. My sliding rear window was open and I could smell raw fuel. I cycled the fuel pump four or five times by turning the key on and off. Still no start so I sat there for a while with the throttle pedal pressed to the floor hopefully to let any excess fuel evaporate or boil off. Called for a ride and tried once more and the old dime fired right up

When I got home and stepped out of the truck more strong raw fuel odor. I see no gas under the truck I can just smell it.  I have a gal pal that has watched my build from the start and finally decided she was ready for a ride. The truck fired right up and I decided to blow the cobs out of it and maybe burn off some gas, it ran great and when I got back to the house it didn't smell of gas so I thought all was well,,wrong. The same thing happened again when I picked my granddaughter up from school. started up just great ran fine until I shut it off at school. About ten minutes later I fired it up it idled just fine and while sitting there talking with her it shuddered and idled down and died. No start Hmmm was it flooded or lacking gas again I cycled the key it had pressure but no start so I mashed the gas for about five minutes and then it fired right up again and ran fine again.

  The mods I've make to the crate 4.3, New mpi replacing the stock scpi with AC Delco parts new distributor, wires, plugs, 78 mm bored and polished throttle body cold air induction 5.7 MAF new MAP sensor, coil, Headers new exhaust from headers to new cat new mufflers ect. The only thing not new is the gas tank and fuel pump but it is putting out 65 pounds ket on motor off and drops to 55 at idle all within specs. any clues aas to where I might start??

2 Answers

Fuel pressure regulator.change fuel filter.sounds like fuel problem..vapor lock..

20,025

how is the fuel pressure leakdown rate when you turn the key on/engine off

1 of 1 people found this helpful.

Your Answer

Chevrolet S-10 Experts

  • #1
    Andrew Olsen
    Reputation
    2,560
  • #2
    John Saffrahn
    Reputation
    1,050
  • #3
    Trebor66
    Reputation
    1,040
View All

Related Models For Sale

Used Ford Ranger
186 Great Deals out of 5,550 listings starting at $999
Used Toyota Tacoma
706 Great Deals out of 45,624 listings starting at $1,000
Used GMC Sonoma
5 Great Deals out of 423 listings starting at $2,150
Used Ford F-150
3,278 Great Deals out of 221,642 listings starting at $1,200
Used Dodge Dakota
82 Great Deals out of 3,630 listings starting at $1,295
Used Chevrolet Blazer
6 Great Deals out of 945 listings starting at $950
Used GMC Sierra 1500
1,193 Great Deals out of 64,579 listings starting at $999
Used Dodge Ram 1500
429 Great Deals out of 11,124 listings starting at $1,495
Used Chevrolet C/K 1500
860 listings starting at $2,603
Used Chevrolet Camaro
456 Great Deals out of 31,607 listings starting at $1,450
Used Ford Mustang
587 Great Deals out of 39,474 listings starting at $1,895

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.