I have a 95 s10 2.2 4 cal and I have put everything on it and today I put an ignition control module on it and it starts and runs smooth til it gets warmed up then it starts backfiring.. HELP PLEASE

Asked by Sep 09, 2016 at 09:07 PM about the 1995 Chevrolet S-10 2 Dr STD Standard Cab SB

Question type: Maintenance & Repair

The new parts I put on it already are a new fuel pump, spark plugs, starter,coil
packs, crank sensor and ignition control module....

2 Answers

10

Have you checked fuel pressure? And check the timing gear, they are bad about the tentioner breaking.

Thanks Monza78

Your Answer

Add photo

Related Questions

Search Chevrolet S-10 Questions

Chevrolet S-10 Experts

#1 Andrew Olsen
Andrew Olsen
Reputation 2,340
#2 Trebor66
Trebor66
Reputation 990
#3 John Saffrahn
John Saffrahn
Reputation 980
View All

Related Models For Sale

Used Ford Ranger
176 Great Deals out of 5,676 listings starting at $950
Used Toyota Tacoma
472 Great Deals out of 41,615 listings starting at $1,995
Used Ford F-150
2,068 Great Deals out of 207,301 listings starting at $1,499
Used GMC Sonoma
5 Great Deals out of 453 listings starting at $2,798
Used Dodge Dakota
137 Great Deals out of 3,794 listings starting at $1,495
Used Chevrolet Blazer
3 Great Deals out of 1,189 listings starting at $1,820
Used Dodge Ram 1500
411 Great Deals out of 10,835 listings starting at $1,400
Used GMC Sierra 1500
761 Great Deals out of 69,110 listings starting at $1,850
Used Chevrolet C/K 1500
861 listings starting at $3,290
Used Chevrolet Camaro
244 Great Deals out of 31,183 listings starting at $369

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.