Transmission

Asked by May 28, 2016 at 01:16 PM about the 1994 Chevrolet S-10 2 Dr LS Extended Cab SB

Question type: Maintenance & Repair

I replaced freez plug on back of engine i had
to drop the transmission ok the
transmission worked fine befor i dropped it i
put it back in and now it dont have reverse
or neutral

1 Answer

250,955

Since you removed the transmission and it worked find before, I'd check the linkage and connections again, make sure everything is assembled correctly.

1 of 1 people found this helpful.
Best Answer Mark helpful

Your Answer

Chevrolet S-10 Experts

  • #1
    Andrew Olsen
    Reputation
    2,370
  • #2
    Trebor66
    Reputation
    1,020
  • #3
    John Saffrahn
    Reputation
    1,000
View All

Related Models For Sale

Used Ford Ranger
172 Great Deals out of 5,551 listings starting at $1,000
Used GMC Sonoma
7 Great Deals out of 439 listings starting at $1,499
Used Toyota Tacoma
559 Great Deals out of 42,350 listings starting at $2,999
Used Ford F-150
2,225 Great Deals out of 182,703 listings starting at $1,500
Used Dodge Dakota
129 Great Deals out of 3,695 listings starting at $1,650
Used Chevrolet Blazer
4 Great Deals out of 1,160 listings starting at $950
Used GMC Sierra 1500
792 Great Deals out of 68,348 listings starting at $1,699
Used Dodge Ram 1500
413 Great Deals out of 10,725 listings starting at $1,500
Used Chevrolet C/K 1500
880 listings starting at $3,195
Used Chevrolet Camaro
421 Great Deals out of 31,920 listings starting at $2,395

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.