fuel pump

Asked by Apr 12, 2017 at 09:50 PM about the 2001 Chevrolet Blazer LS 4-Door 4WD

Question type: Maintenance & Repair

Put in new fuel pump and it was running for a few
minutes then it stopped. Then after awhile the
pump starts to work again then stops that is what
happened to the old pump so I changed it so any
ideas on what it could be..

1 Answer

First, check your ground at the connector while it's running. Could be an intermitint problem. Also make sure the fuse is tight in it's holder. Any debris or bad connections should be taken cleaned and repaired.

Your Answer

Chevrolet Blazer Experts

  • #1
    Andrew Olsen
    Reputation
    2,180
  • #2
    yetilikesbeer
    Reputation
    1,440
  • #3
    Rowefast
    Reputation
    1,110
View All

Related Models For Sale

Used Chevrolet Tahoe
888 Great Deals out of 39,790 listings starting at $1,990
Used Chevrolet TrailBlazer
50 Great Deals out of 4,064 listings starting at $1,495
Used Chevrolet S-10
10 Great Deals out of 1,172 listings starting at $1,980
Used Chevrolet Silverado 1500
3,023 Great Deals out of 162,634 listings starting at $1,500
Used GMC Jimmy
195 listings starting at $2,989
Used Ford Explorer
1,175 Great Deals out of 64,183 listings starting at $1,499
Used Ford F-150
3,268 Great Deals out of 224,290 listings starting at $1,250
Used Chevrolet Camaro
526 Great Deals out of 31,057 listings starting at $1,450
Used Jeep Grand Cherokee
1,066 Great Deals out of 67,520 listings starting at $950
Used Ford Mustang
445 Great Deals out of 42,042 listings starting at $1,488
Used Toyota 4Runner
319 Great Deals out of 27,206 listings starting at $1,900

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.