2001 Chevy Blazer LS Will Not start


Asked by Sep 12, 2014 at 07:45 AM about the 2001 Chevrolet Blazer LS 4-Door 4WD

Question type: Maintenance & Repair

So on Sunday sept 8th I started my blazer up ( took a bit she didn't want to do much but crank) she did start and stall once and started right up afterwards. I went across an intersection she didn't want to accelerate right away heard a small ping and she continued to run as normal.  I went and ran errands for about 30 mins at 3 different places... turned her off she started right up and continued to run normally I parked her in my drive way and went to leave for work an hour later and she would do nothing but crank over. Crank is normal at this point not fast or slow.  I checked fuses all is fine. Listened for the fuel pump which is priming normally. So I checked to see if she had spark and small spark. All spark plugs are brand new. So went on to check the distrubtor and rotor button. They seemed find cleaned them up while I was already messing with it. Put it back together still no start just cranking. So I continued on to replace fuel filter. I did not put it on correctly im assuming since I found a small slow leak at the back fuel line and started over removing the the new fuel filter and putting it back on no fuel leak but when I removed it did get quite a bit of gasoline. Old fuel filter had black crap in it so regardless of wether that was the problem she needed a new one. Still no start. So I replaced the distributor and the rotor button and still no start rechecked to see if she had spark... now that was a big spark. scared the crap out of me lol... check my gauges started saying the voltage on battery was inbetween 9 and 14. So removed battery took it to get tested and its fine. Re installed battery now it only sits at a 9 on guage or right above 9. Try to turn her over and now hearing a gurgling noise near throttle body. checked to see if butterfly was moving and it is moving correctly not stuck just as smooth as it should be. try to start her up had driver's door open complete loss of power like theres no battery. Slam door shut power comes back on and she would still crank over.  decided to let her sit for an hour and tried to see if I could find anything on google go back out to try and see if I could get her to start (since Ive started putting my own elbow grease into this thing she's been stubburn) and now I hear a click and all power is lost immediately no crank over until I either take the keys out of the ignition and put them back or open and slam driver/passenger doors. When keys go in the gauges do a quick sweep... lights are on as normal, radio is on as normal check engine light is on but that has been on since ive gotten the truck back in may of 2013 and put new tires on her. Read in the manual that it wasn't that common. Battery light has shown up but I wouldn't think she would crank over if alternator or the starter were bad... I'm really at a loss ive called all the chevy dealers and talked to the mechanics they have no idea and want me to bring her in for a diagnostics I  don't really have to nickels to rub together let alone $100 to hook her up to a computer. I've also consulted my father who is a mechanic and a coworker who is a mechanic and they also are stumped. I was thinking originally after fuel filter that it was the pump as that's a common problem, but she could be heard when ignition is activated. I've checked fuses and everything... could there maybe a bad ground? I

8 Answers


It sound,s to me like a fuel issue,check the fuel pump,and what you said about the filter,black stuff,that may be what,s got the pump,just because you hear it ,dosn,t mean it is pumping right,it take,s a lot of pressure to open the injector.s,this would all so explain the slow accelaration.


But what about the electrical issues would that also mess with that?

3 of 3 people found this helpful.

As far as the power issue,check the ground,s real good, to battery and to frame.if you can slam a door and get power,there is a loose link,in something.


so I replaced a terminal on positive battery found that original had a crack... no loss of power when opening door or anything power stays on fine. Tried to start click loss of power. When key is first put in airbag blinks 8 times no pause and shuts off.

1 of 1 people found this helpful.

Need replaced the batteries cables (positive and negative )

Where you from amanda ?




oh I miscounted it blinks 7 times not 8 lol @_@

Your Answer


Looking for a Used Blazer in your area?

CarGurus has 731 nationwide Blazer listings starting at $900.


Chevrolet Blazer Experts

  • #1
    Andrew Olsen
  • #2
  • #3
View All

Related Models For Sale

Used Chevrolet TrailBlazer
42 Great Deals out of 3,283 listings starting at $1,650
Used Chevrolet Tahoe
590 Great Deals out of 37,467 listings starting at $1,699
Used Chevrolet S-10
8 Great Deals out of 995 listings starting at $999
Used Chevrolet Silverado 1500
2,175 Great Deals out of 151,474 listings starting at $1,995
Used GMC Jimmy
153 listings
Used Ford F-150
2,521 Great Deals out of 220,358 listings starting at $1,222
Used Ford Explorer
847 Great Deals out of 64,621 listings starting at $2,000
Used Chevrolet Camaro
236 Great Deals out of 30,155 listings starting at $4,980
Used Jeep Grand Cherokee
843 Great Deals out of 74,143 listings starting at $500
Used GMC Yukon
375 Great Deals out of 19,007 listings starting at $2,500
Used Chevrolet Suburban
421 Great Deals out of 22,354 listings starting at $2,495

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.