Fuel pump not running

Asked by Mar 06, 2016 at 03:47 PM about the 1990 Chevrolet S-10 STD Standard Cab SB

Question type: Maintenance & Repair

So I replaced the relay, and the fuel pump on my 90
s10. I have 12 volts to the relay Their is no fuel
pump fues I have looked every where for one. Well
I have only 8 volts to the pump and it's not kicking
on. Where is the voltage going?

1 Answer

Did you ever figure out the problem on your truck I'm having the same problem

Your Answer

Chevrolet S-10 Experts

  • #1
    Andrew Olsen
    Reputation
    2,660
  • #2
    John Saffrahn
    Reputation
    1,090
  • #3
    Trebor66
    Reputation
    1,070
View All

Related Models For Sale

Used Ford Ranger
126 Great Deals out of 4,992 listings starting at $1,299
Used GMC Sonoma
363 listings starting at $2,150
Used Ford F-150
3,016 Great Deals out of 229,513 listings starting at $1,300
Used GMC Sierra 1500
1,106 Great Deals out of 61,547 listings starting at $1,295
Used Dodge Dakota
81 Great Deals out of 3,427 listings starting at $1,475
Used Chevrolet Blazer
6 Great Deals out of 842 listings starting at $950
Used Chevrolet Camaro
385 Great Deals out of 31,356 listings starting at $3,495
Used Chevrolet C/K 1500
818 listings starting at $2,600

Used Cars For Sale

2004 Chevrolet S-10 For Sale
34 listings starting at $5,650
2003 Chevrolet S-10 For Sale
4 Great Deals out of 279 listings starting at $2,995
2002 Chevrolet S-10 For Sale
204 listings starting at $950
2001 Chevrolet S-10 For Sale
155 listings starting at $3,490
2000 Chevrolet S-10 For Sale
158 listings starting at $4,500

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.