(1990 560sel) Starting Issue (Please Read)

Asked by May 11, 2011 at 05:08 PM about the 1990 Mercedes-Benz 560-Class 4 Dr 560SEL Sedan

Question type: Maintenance & Repair

While I'm jumping my car off it starts while still connected to jumper cables and running car its connected to. I disconnect the jumper cables while my 1990 560sel is still running. It stays running and I can drive around. But once I shut it off it goes dead. It slowly became harder and hared to start over time. Everything works fine that I can tell. What do you guys think? (Going on a trip and need it working proper.)

1 Answer

275

If the battery is pretty new you may have a parasitic draw. You would have to let the vehicle go to sleep and check for a current draw above 50mA or so.

Your Answer

Mercedes-Benz 560-Class Experts

  • #1
    Sailor
    Reputation
    210
  • #2
    RickELake
    Reputation
    130
  • #2
    Mick Stewart
    Reputation
    130
View All

Related Models For Sale

Used Mercedes-Benz SL-Class
54 Great Deals out of 2,704 listings starting at $3,950
Used Mercedes-Benz 300-Class
192 listings starting at $3,997
Used Chevrolet Corvette
253 Great Deals out of 22,051 listings starting at $2,500
Used Mercedes-Benz G-Class
19 Great Deals out of 1,262 listings starting at $19,995

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.