1990 300E -idles rough and stalls at stops

60

Asked by Feb 08, 2013 at 08:21 PM about the 1990 Mercedes-Benz 300-Class 4 Dr 300E Sedan

Question type: Maintenance & Repair

cold start is fine, after it warms up it idles rough and stalls at stops, sometimes it will restart most of time it wont
start,  I think the mixture is to rich for one. also noticed that when it doesnt restart i have been able to turn the
ignition key back a second after it cranks it sputters and then starts, also when warmed up it will sometimes run
fine in idle but , when i put it in gear it sputters and wants to die. sometimes it does die. other times it doesnt do it
when in gear, but it will do it after its been running for 10 minutes or more. a

9 Answers

21,085

E.G. bob give him the last letter!

18 of 18 people found this helpful.
21,085

clogged cateltic converter maby,run some cleaner thrue carb,air horn,intake all same thing and when it stalls hold peddle to floor that shuts gas off for flooding,for now

2 of 2 people found this helpful.
265

I'm positive it is not a clogged cat. Tonnes of the 300E and 420SEL have this problem (My 420 is doing the exact same thing to me). I believe it's a major Vacuum leak. Check around your Throttle Body, CIS Unit, and Brake Booster. Hopefully your leak is easier to find.

4 of 4 people found this helpful.
60

I checked the brake booster a few months ago , and wasnt that, i will have to get a cigar tomorrow and smoke the engine see if i can find a leak. i was leaning towrds it maybe being the coolant sensor, thinking its flooding the engine, but dont know how to check it

2 of 2 people found this helpful.
60

@7jimmy7 there is no carb its cis

265

You're talking the cold start injector? Very possible, though it could just as likely be that injectro is leaking as the sensor acting up. The injector is right there towards the front of the engine if you're wanting to pull it out and see if it's leaking or still spraying when the engine is hot.

1 of 1 people found this helpful.
40

I will check it out, I was actually referring to the cold temp sensor, if its saying its 30 below zero then it will dump fuel into the system, but the thing that gets me is that in idle its pretty much normal , only acts up in gear

4 of 4 people found this helpful.
20

Sitting on the side of the road in my 1990 300SEL waiting for AAA, I've had almost everything replaced to fix this problem, literally 10k into this 4k car... And no one mentioned a vacuum leak... $100 says that's it, it's thre only thing left.

2 of 2 people found this helpful.
10

Could be the Bosch EHA valve. It can be worn out and become temperature sensitive to functioning, working well when engine is cold, but irratic when warm. The cool gas going into it complicates the picture because once you stop the car the gas warms up in the area and makes starting difficult until cool gas reaches it again, but it may not be cool enough anymore with a hot engine under it. New, these are very expensive little critters.

1 of 1 people found this helpful.

Your Answer

300-Class

Looking for a Used 300-Class in your area?

CarGurus has 184 nationwide 300-Class listings starting at $3,997.

ZIP:

Mercedes-Benz 300-Class Experts

  • #1
    James Ramond
    Reputation
    240
  • #2
    Tom Demyan
    Reputation
    220
  • #3
    COMETGUY61
    Reputation
    200
View All

Related Models For Sale

Used BMW 3 Series
1,047 Great Deals out of 31,561 listings starting at $1,000
Used Mercedes-Benz SL-Class
46 Great Deals out of 2,722 listings starting at $4,500
Used Mercedes-Benz G-Class
21 Great Deals out of 1,284 listings starting at $19,995

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.