1990 300E -idles rough and stalls at stops

40

Asked by Feb 08, 2013 at 08:21 PM about the 1990 Mercedes-Benz 300-Class 4 Dr 300E Sedan

Question type: Maintenance & Repair

cold start is fine, after it warms up it idles rough and stalls at stops, sometimes it will restart most of time it wont
start,  I think the mixture is to rich for one. also noticed that when it doesnt restart i have been able to turn the
ignition key back a second after it cranks it sputters and then starts, also when warmed up it will sometimes run
fine in idle but , when i put it in gear it sputters and wants to die. sometimes it does die. other times it doesnt do it
when in gear, but it will do it after its been running for 10 minutes or more. a

9 Answers

18,535

E.G. bob give him the last letter!

15 out of 15 people think this is helpful.
18,535

clogged cateltic converter maby,run some cleaner thrue carb,air horn,intake all same thing and when it stalls hold peddle to floor that shuts gas off for flooding,for now

2 out of 2 people think this is helpful.
245

I'm positive it is not a clogged cat. Tonnes of the 300E and 420SEL have this problem (My 420 is doing the exact same thing to me). I believe it's a major Vacuum leak. Check around your Throttle Body, CIS Unit, and Brake Booster. Hopefully your leak is easier to find.

4 out of 4 people think this is helpful.
40

I checked the brake booster a few months ago , and wasnt that, i will have to get a cigar tomorrow and smoke the engine see if i can find a leak. i was leaning towrds it maybe being the coolant sensor, thinking its flooding the engine, but dont know how to check it

2 out of 2 people think this is helpful.
40

@7jimmy7 there is no carb its cis

245

You're talking the cold start injector? Very possible, though it could just as likely be that injectro is leaking as the sensor acting up. The injector is right there towards the front of the engine if you're wanting to pull it out and see if it's leaking or still spraying when the engine is hot.

1 out of 1 people think this is helpful.
20

I will check it out, I was actually referring to the cold temp sensor, if its saying its 30 below zero then it will dump fuel into the system, but the thing that gets me is that in idle its pretty much normal , only acts up in gear

2 out of 2 people think this is helpful.
20

Sitting on the side of the road in my 1990 300SEL waiting for AAA, I've had almost everything replaced to fix this problem, literally 10k into this 4k car... And no one mentioned a vacuum leak... $100 says that's it, it's thre only thing left.

2 out of 2 people think this is helpful.

Could be the Bosch EHA valve. It can be worn out and become temperature sensitive to functioning, working well when engine is cold, but irratic when warm. The cool gas going into it complicates the picture because once you stop the car the gas warms up in the area and makes starting difficult until cool gas reaches it again, but it may not be cool enough anymore with a hot engine under it. New, these are very expensive little critters.

Your Answer

Add photo

Related Questions

  • 1990 mercedes 300E high idle problem 2 answers

    my 1990 mercedes 300e starts and idles at about 900-1000 rpm but when i drive it the idle at at stop increases to 1500 to 2500 rpm any answers?

    1990 Mercedes-Benz 300-Class 4 Dr 300E Sedan

    -

    Maintenance & Repair

  • former specialty mechanic shares secrets 8 answers

    hey guys i just wanted to share some of the common problems that I have with my 1993 300e 2.8 (m104 engine) that happens to every car. 1. if you have a low idle speed and you car dies at traffic light...

    1993 Mercedes-Benz 300-Class 4 Dr 300E 2.8 Sedan

    -

    Maintenance & Repair

  • starts cold but when hot hard start 1 answer

    1987 300E mbenz starts quick and runs without stalling but when stops and turn off engine it will not start like no gas but gas pressure is good, suspect electrical coz not conitinous spark from plu...

    1987 Mercedes-Benz 300-Class 300E Sedan

    -

    Maintenance & Repair

  • My 87 300E MB is burning oil won't pass smog 7 answers

    Hello, My 87 300 E is burning oil and can't pass a smog test. Runs rough.

    Mercedes-Benz 300-Class

    -

    Maintenance & Repair

  • -oil pressure sending unit repair? 1 answer

    oil pressure drops to 0 at stop signs and then back to 3.0 after I accelerate. has a new head gasket and am wondering if a new oil pressure sending unit would cure the problem? cars runs well for 132k

    1990 Mercedes-Benz 300-Class 4 Dr 300E Sedan

    -

    Maintenance & Repair

300-Class

Looking for a Used 300-Class in your area?

CarGurus has 204 nationwide 300-Class listings starting at $6,950.

ZIP:

Search Mercedes-Benz 300-Class Questions

Mercedes-Benz 300-Class Experts

#1 James Ramond
James Ramond
Reputation 200
#1 Tom Demyan
Tom Demyan
Reputation 200
#3 joemom
joemom
Reputation 170
View All

Related Models For Sale

Used BMW 3 Series
1,830 Great Deals out of 41,344 listings starting at $1,250
Used Mercedes-Benz SL-Class
113 Great Deals out of 3,484 listings starting at $1,500
Used BMW 5 Series
673 Great Deals out of 17,820 listings starting at $1,500