When my car engine temp gauge gets up to temp, it will shoot back down to 160..and if i turn off the engine while it is down, it takes a while for it to start again. Does anyone know why?

Asked by Mar 31, 2015 at 02:59 PM about the 2005 Chevrolet TrailBlazer LS 4WD

Question type: Maintenance & Repair

1 Answer

75,775

Sounds like a bad coolant temp sensor or a bad wiring connection at the coolant temp sensor. HTH. -Jim

Your Answer

Chevrolet TrailBlazer Experts

  • #1
    bigdogracer
    Reputation
    1,050
  • #2
    Tom Demyan
    Reputation
    930
  • #3
    dandyoun
    Reputation
    720
View All

Related Models For Sale

Used Chevrolet Tahoe
784 Great Deals out of 40,137 listings starting at $1,799
Used Jeep Grand Cherokee
858 Great Deals out of 72,063 listings starting at $900
Used Chevrolet Silverado 1500
2,597 Great Deals out of 157,665 listings starting at $1,500
Used GMC Envoy
38 Great Deals out of 1,747 listings starting at $1,100
Used Chevrolet TrailBlazer EXT
6 Great Deals out of 902 listings starting at $1,988
Used Dodge Charger
305 Great Deals out of 35,593 listings starting at $1,999
Used Ford Explorer
1,018 Great Deals out of 67,538 listings starting at $1,200
Used Chevrolet Equinox
1,007 Great Deals out of 78,295 listings starting at $1,843
Used Chevrolet Impala
466 Great Deals out of 31,447 listings starting at $1,000
Used Dodge Durango
260 Great Deals out of 24,718 listings starting at $1,500
Used Ford F-150
2,943 Great Deals out of 230,825 listings starting at $1,300
Used Chevrolet Blazer
5 Great Deals out of 804 listings starting at $950

Used Cars For Sale

2007 Chevrolet TrailBlazer LS 4WD For Sale
6 Great Deals out of 187 listings starting at $2,744

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.