I've got a 1996 Toyota T100 4 cyl 2wd. I can start it right up and it will sit there and idle but as soon as i go to accelerate, it wants to shut off.

170

Asked by Nov 01, 2013 at 09:33 PM about the 1996 Toyota T100 2 Dr STD Standard Cab LB

Question type: Maintenance & Repair

I've replaced the spark plugs, plug wires, and the distributor but it still wants to shut off.

2 Answers

the battery connection to frame...the 1/0 black battery cable needs to make a SOLID connection...wirebrush the territory that takes this 1/0 lug and the lug...the corrosion happens from dis-similar metals exchanging bits of one another in this 300 amp exchange...daily~ Coarse Wirebrush please....and NEW battery if yours is older than five~(check knock off labels on top of battery)~

1 of 1 people found this helpful.
20

Same thing happened on my 1993 T100. It gave a code for the Mass Air Flow Meter

Your Answer

Toyota T100 Experts

  • #1
    BURT100
    Reputation
    230
  • #2
    Tom Demyan
    Reputation
    210
  • #3
    mountainman1
    Reputation
    130
View All

Related Models For Sale

Used Toyota Tacoma
560 Great Deals out of 40,667 listings starting at $2,600
Used Toyota Pickup
87 listings starting at $2,691
Used Toyota 4Runner
348 Great Deals out of 29,247 listings starting at $1,500
Used Ford F-150
3,015 Great Deals out of 230,521 listings starting at $1,300
Used Ford Ranger
130 Great Deals out of 4,993 listings starting at $999
Used Toyota Corolla
930 Great Deals out of 70,174 listings starting at $1,479
Used Dodge Ram 1500
322 Great Deals out of 10,798 listings starting at $1,950
Used Chevrolet S-10
8 Great Deals out of 1,146 listings starting at $950
Used Chevrolet C/K 1500
808 listings starting at $2,600
Used Toyota Supra
52 listings

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.