Random warm start issue. Frustrating, Please help

Asked by Oct 15, 2014 at 03:44 AM about the 1995 Toyota Previa 3 Dr LE Supercharged Passenger Van

Question type: Maintenance & Repair

95 LE S/C. 150.000 miles. Engine starts fine when cold. Will crank but wont start when engine is normal operating temperature. There is a strong oder of fuel when this occurs. I've only owned van for 2 weeks. Dont know much about it when purchased on 10/1 But after researching its KBB value and owner reviews for $1200 i couldn't pass it up. Here are some quirks I've noticed in the 300 miles that ive driven it.
1 The warm start issue. (Does it 9 outta 10 warm starts)
2 transmission will seldom jump from drive 3 to OD, back and forth. Usually shifts fine but has happened twice.
3 At first cold start it runs and will idle great. 45 seconds after start up I hear a single click/chirp and engine idles poorly and will stall out if not I'm not there to feather the throttle. As soon as throttle is pushed it idles fine only to repeat the problem 1 minute  
later.
4 Occasinally it will idle up on its own. (Has done this twice)
5 getting terrible fuel mileage.
6 Check engine light is not on and does not illuminate when key is in on position. I have never seen it come on yet. Passed emissions on 10/4/2014.
I read that if the check engine light does not turn on for at lease 2 seconds when key is in on position its a possible bad or faulty ECU, or there's a no power issue to ECU.
Van has New fuel pump and filter. New "stock" air filter. New plugs, wires, rotor and cap. Oil change, Coolant changed and Throttle body has been cleaned.
Aside from these "hopefully" minor issues everything works like it should. Is Extremely fast and has plenty of power.
  Any suggestions will be appreciated.  Thanks for you time and reading this mini novel.  On behalf of the Band, I hope I passed the audition.

1 Answer

10

Check idle control sensor,makes motor rpm raise when you put it in gear or turn on ac..google model and year.Ask where sensor is located.you can usually unplug sensor and run jump wire.

1 out of 1 people think this is helpful.

Your Answer

Add photo

Related Questions

Search Toyota Previa Questions

UK Questions

Are you a UK consumer? CarGurus now has a discussion forum in the UK.

Toyota Previa Experts

#1 ttdsgnr5
ttdsgnr5
Reputation 150
#2 martyman
martyman
Reputation 130
#2 gertis
gertis
Reputation 130
View All

Related Models For Sale

Used Toyota Tacoma
712 Great Deals out of 32,122 listings starting at $2,000
Used Toyota RAV4
821 Great Deals out of 53,146 listings starting at $2,199
Used Toyota Supra
38 listings
Used Toyota Land Cruiser
22 Great Deals out of 1,177 listings starting at $4,995
Used Honda Odyssey
368 Great Deals out of 27,550 listings starting at $1,095
Used Toyota Pickup
117 listings starting at $4,995
Used Volkswagen EuroVan
89 listings starting at $4,900
Used Toyota Tercel
29 listings
Used Toyota Camry
1,196 Great Deals out of 93,143 listings starting at $700