Engine oil stops supplying to the engine after engine runs for some minutes, had the oil pump changed still the problem persists..... Please what do I need to check again

Asked by Apr 04, 2016 at 05:40 PM about the 1995 Toyota Previa 3 Dr LE Passenger Van

Question type: Maintenance & Repair

Whenever I start the engine, the engine oil pressure indicator goes of and the
engine runs smoothly. But after some minutes the indicator light comes on
and the engine starts giving a knocking sound. A mechanic changed the oil
filter and straightened the bottom tray and changed the oil pump but still the
problem persists. Please help

1 Answer

21,730

Sounds like the rod bearings are going bad. If he changed the oil pump he could have also changed the rod bearings since the oil pan was off already.

Your Answer

Toyota Previa Experts

  • #1
    ttdsgnr5
    Reputation
    180
  • #2
    her94previa
    Reputation
    170
  • #3
    gertis
    Reputation
    160
View All

Related Models For Sale

Used Toyota 4Runner
256 Great Deals out of 33,056 listings starting at $950
Used Honda Odyssey
332 Great Deals out of 36,474 listings starting at $1,499
Used Toyota Camry
789 Great Deals out of 70,452 listings starting at $1,000
Used Toyota RAV4
417 Great Deals out of 74,571 listings starting at $1,995
Used Toyota Corolla
553 Great Deals out of 66,960 listings starting at $900
Used Toyota Tacoma
412 Great Deals out of 44,286 listings starting at $1,995
Used Honda CR-V
470 Great Deals out of 72,544 listings starting at $1,500
Used Toyota Supra
48 listings
Used Audi A4
195 Great Deals out of 12,599 listings starting at $1,800
Used Toyota MR2
17 listings
Used Toyota T100
47 listings starting at $7,490

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.