A/C COMPRESSOR WILL NOT ENGAGE AND NO FAN .

Asked by Nov 07, 2011 at 04:38 AM about the 1993 Subaru Loyale 4 Dr STD Wagon

Question type: Maintenance & Repair

I HAVE NO VOLTAGE GOING TO BLOWER MOTOR (FAN). I JUMPED THE BLOWER MOTOR AND IT'S OK . NO VOLTAGE GOING TO COMPRESSOR . JUMPED COMPRESSOR CLUTCH AND IT'S OK . I HAVE VOLTAGE AT ALL FUSES AND FUSEABLE LINKS . CAN ANYONE HELP ME OUT ? THANKS RED

1 Answer

135

Your Rev Speed Sensor on your AC compressor is bad or is misaligned. Make sure that the sensor on the front of your condenser is tightened down and has the proper clearance to pickup your condenser engaging. Plus your system could have the wrong pressure in it to operate and the pressure sensor is keeping it from running.

1 of 1 people found this helpful.

Your Answer

Subaru Loyale Experts

  • #1
    Rowefast
    Reputation
    250
  • #2
    Tom Demyan
    Reputation
    170
  • #3
    TheSubaruGuruBoston
    Reputation
    120
View All

Related Models For Sale

Used Toyota 4Runner
349 Great Deals out of 27,129 listings starting at $1,800
Used Ford Explorer
1,265 Great Deals out of 70,145 listings starting at $1,000
Used Subaru Legacy
244 Great Deals out of 15,196 listings starting at $1,795
Used Mitsubishi Mirage
26 Great Deals out of 4,053 listings starting at $3,777
Used Subaru GL
2 listings

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.