Windshield wipers

Asked by May 19, 2015 at 02:48 PM about the 2004 Mercury Grand Marquis LS Ultimate

Question type: Maintenance & Repair

My wipers stopped last week and the next day they started working okay and today they don't work on slow or intermitt and only work on high speed and the washer wiper doesn;t work

37 Answers

I'd clean battery ground to chassis connection with a wirebrush to insure solid ground connection to the chassis~

1 out of 1 people think this is helpful.
25,905

Yeah dont worry with the battery ground thats not the issue here. Its could be the motor but sounds like the switch would be more likely in this case.

2 out of 2 people think this is helpful.
22,425

Listen to kbro - that multifunction switch messes up frequently. Especially since the wipers don't usually get used for months at a time and the switch is at the very end of a lever that does get used all the time. There would be more failures than only the wipers if it were a ground concern.

3 out of 3 people think this is helpful.
40

a car dealer is charging me$ 310.00 to fix thwe problem with the wind shield wipers

4 out of 4 people think this is helpful.
415

Sorry Guys so far you are all wrong.I have the same issue and changed out the Multifuction Switch and every thing you all said.It looks to me that it might be the Light Control Module LCM..That is the only thing that I have not looked into.The Windshield wiper motor receive power from the following. 1. Multifunction switch 2.Lighting control Module 3.ignition switch 4.battery junction box 5.central junction box.The following components are integrated into the wiper motor.1.Wiper motor module. 2.high/low speed relay.3.run/park sensor-Hall effect.4.washer pump relay.I am still looking into this so please contact me if you would like me to fax what I have on this it is about 17 page's all about Diagnosis and Testing Wipers and Washers System.I would post it but have never uploaded to this site before.Please e-mail me if you need this paper work.This is for all 2004 grand marquis and covers Crown Vic and Marauder. So I will get back to you on this.Hope I can help someone.

12 out of 12 people think this is helpful.
25,905

just because you changed the switch on yours and that didn't fix it doesn't mean that's its not the problem in this case. there isn't one fix for every problem. The motor does not receive power from the LCM. When the wipers are turned on, the LCM receives a momentary power input on circuit 28 (BK/PK), indicating the wiper motor has passed through a parking position. At this time the LCM supplies 12 volts on circuit 502 (GY), which powers the low beams of the headlamps. This feature is not available with the police package. The LCM does not effect the operation of the motor or switch it just receives a signal as previously stated.

2 out of 2 people think this is helpful.
415

ha ;Kbro,guy I never said that there is a one fix for all.And I am not trying to tell you anything,and there is no one fix all.I am stating that the post above is a problem that is very close the same that I have.And yes you are correct about what you stated as to LCM is word for word for the Safety Feature is what you are stating which i agree.AND on the LCM yes that is correct but my thought is that is the LCM giving the Momentary power Might it be shorted I don't know yet I just stated that I did not check it that it might be an issue.And yes you are most correct that feature is not available with the police package.Look I am trying to help not get into a who knows what issue.I try not to just put parts into it until it works but in this case the most obvious cause looked to be the same thing you said the Multifunction Switch,I tried that first then started looking to this site to see if anyone had the same issue.Let me tell you what I did 1st and maybe we can work to solve this for the better good and that everyone with lighting-wiper issues might get the help they need without spending money for part's we all know cost to much, I will do some pinpoint test on the the wiper motor seeing we have all those integrated components in the motor, And by the way my wiper switch is in the off mode and my wipers are working in delay mode,what I ment stating as we had the same type of issue was that we both had it happen the same way,the issue was there one day and came back,neverless the wipers are the issue and I will keep checking until I find it.Sorry if you think I was out of line but in my experience nothing get ruled out until the issue is solved.

5 out of 5 people think this is helpful.
22,425

"Sorry Guys so far you are all wrong" - yup, sounds like the voice of authority. In our Fleet of 800+ Crown Vic Police Interceptors (same car - more equipment) this is a common problem. Not to say that it can't be something else but, the Multifunction switch is the MOST COMMON FAILURE. kbro isn't stupid.

3 out of 3 people think this is helpful.
415

Tracy; I do not feel kbro is is stupid I honestly think the opposite because he came right out word for word the action that was most obvious and seems to have his facts.Look I might have stated that comment different might I thought you were going to be offended.So I will take your comment. So let it go from here it is not productive I all ready posted what I wanted to say to kbro and it seems he has the stones to say whats on his mind.Sometimes the obvious does not apply.Fist of all I have not seen the guy repost so maybe he took it in to the dealer or the obvious worked in his case he changed out his multifunction switch.In my case it is not the corrective answer. But tell you what just to let other know what the issue is I will get back to this page just so others might look at whatever other issues are out there.I will state it again sorry if you felt offended in some of my wording.I meet not to be a know it all.

1 out of 1 people think this is helpful.
25,905

Its all good no hard feelings. Except to judge roy. Get so tired of all his answers saying clean the battery ground for any given issue. Oh you have a vibration? Better clean the battery ground that will take care of it!

2 out of 2 people think this is helpful.
415

Thanks Kbro,all good on this side. seeing you are here I thought I might tell you of a post on this same site that the guy has a 2007 grand marquis and It was almost what I would of said to get to the detail of my issus.it is below in the related questions listed as wipers go on in delay mode. see what you think about that he stated his wiper motor started a fire and he had to put it out.let me know what you feel about that .thanks

2 out of 2 people think this is helpful.
25,905

Sounds like the motor was at fault. I have put lots of wiper motors on along with switches. In his case if the motor clicks that means its getting power and ground. Sounds like he got a bad motor.

3 out of 3 people think this is helpful.
415

that was the direction I was going today but it started to downpour rain on me.That's what I was talking about when they integrated into the wiper motor.1.Wiper motor module. 2.high/low speed relay.3.run/park sensor-Hall effect.4.washer pump relay. I was thinking that a short inside the motor might cause an issue,Also I forgot to tell that my light went on while set in auto mood and when this started I was able to shut them off with the switch.I have half the job done just need to take the 3 bolts out to the wiper motor.This guy said he replaced his motor but after the fire.I have not figured out why the lights came on yet but I do think it could be related to that temp signal .We will see soon. Thanks I will get back to you when I install new motor,It take me some time I get a lot of pain when bending into an engine due to past problem,but thanks it gives me a better feeling some thinks it might be the same.good job.

3 out of 3 people think this is helpful.

@ John...wipers not working...I recommend using a product called "rain-x" is very effective and makes it so you don't even need any wipers...I kid you not...have had the same bottle for twenty years~!

1 out of 1 people think this is helpful.

....while you're in there you should "bench test" the motor to make sure that it is okay....and the module or GROUND to the system is at fault~

1 out of 1 people think this is helpful.
25,905

Judge I still don't like you or your answers you are a obnoxious person. your the one whom cussed me out in a private message. or have you forgot that already, that would be convenient. there really is something wrong with you. If you have something good to ad that's fine just don't address me in any of your answers. I'm over you and all your non sense.

3 out of 3 people think this is helpful.

How long can you expect to survive disrespecting the judge? 42,985 does not happen by itself, my friend~ am quite finished with you and your bad attitude~ CarGurus has been notified...simply because of your "attacking an individual" numbers are out of this world...people notice when you are a naughty boy~...mr. too much of a coward to show your face~!

1 out of 1 people think this is helpful.
25,905

Who did i attack? So yeah you have multiple accounts to boost your score. Gurus was also on your case about the ridiculous private message you sent me. Ive neved cussed you out. Go else where and leave me alone i have asked you enough

3 out of 3 people think this is helpful.
25,905

Ive never have disliked anyone ive never met before but you took the cake on that. I still have the message you sent me if you want me to post it again?

2 out of 2 people think this is helpful.
25,905

so you were saying? I didn't attack anyone. I simply gave correct information to someone who said I was wrong. But I guess that considered attacking people now. If I'm attacking people what would you call that message? Like I said just leave me alone I am sick of you.

2 out of 2 people think this is helpful.
25,905

Without using foul words unlike some. Just saying.

2 out of 2 people think this is helpful.
22,425

@ kbro - the dude's a loser. Just continue to let him be a loser. The integrity, honesty and helpfulness you (and a few others) demonstrate on this forum far outweigh anything this pathetic "Battery Changer " has to offer.

5 out of 5 people think this is helpful.
25,905

Well said Tracy. He just gets on my last nerve sometimes. I just need to learn to ignore it.

2 out of 2 people think this is helpful.

John has discovered the 'delete' feature...has NOT bench tested the unit NOR has tried RAIN-X, but dismisses this product as not a thing before giving it the ole' college try...kbro....what can I say, other than you have to spend time in an Engineering office to understand these politics...which your "get along with everyone" biscuit is being revealed...never have I done anything to try and annoy you my friend, but when it came time to hand out the carguru caps....you were not asked of your address...neither tracy...what's the Idea of having two faces on the avatar? now you know who you are talkin' to....a motor.~

22,425

I'm just getting started on CarGurus and you cheat. Engineer? They don't live in the real world.

1 out of 1 people think this is helpful.

...never said I was an Engineer...a Mechanical Design Draftsman....temp rude hack with no bennies~ a mechanic was perfectly brutal work, with brutal people...but stuck by myself as their Sunday guy with tow-ins lording above you...tappin' their foot, askin' when they will be able to drive out of there is as rough a playfield as it gets for "an expert on All makes foreign and domestic"....am glad someone loves you tracy...not sure how YOU came to be a GURU~

25,905

When tracy gives an answer its an intelligent one. He's a guru on crown vics and similar body styles for sure. While others are telling people that ford diesels have timing chains......you know who you are. And thats just one example of many. As for my avatar get over it. I'm a motor with a large super charger and my battery to chassis ground are clean and tight i can assure you. My windshield wiper motor may not work but no worries i have rain x on my side im good to go. Disclaimer: rain x is awesome i use it. Bur its not a fix for a inop. Safety feature on your vehicle.

2 out of 2 people think this is helpful.
10

Mine would only work on high...2005 Mercury Marquis I was told it was the Wiper Motor...300.00 later...they work.

1 out of 1 people think this is helpful.
30

Hey guys, I have a 2010 Grand Marquis that the wipers will not turn off. The off position is a little faster than the slowest intermittent position. Right now I have pulled the 30 amp fuse in the fuse/relay box under the hood. I need some schematics so I can troubleshoot. The switch (speed and push for fluid) I assume is what you are calling the multifunction switch feels good but that does not mean much. Any suggestions. Thanks, Ron

3 out of 3 people think this is helpful.
50

1992 marquis wipers stop working. I was hearing clicking and the wipers were twitching for a while before they stopped. I've changed the switch, the module, and the motor and they still won't work.....help me please!!!!!!

5 out of 5 people think this is helpful.
45

i have a 1997 grand marquis and the wipers stopped working. I dont hear any clicks nothing? Before when wipers wouldnt come on i would play with switch to make wipers come on but now nothing? It froze at a quarter up the windshield. I wiggled it thinking it might take of but nothing. Is this the turn switch signal where its all connected to each other with lights blinker and windshieldwasher/ can anyone help me? Thanks Peeton

4 out of 4 people think this is helpful.
10

Similar same wiper problem on my elderly mother's Grand Marquis. Question: Does anyone makes replacement parts for Ford/Mercury that are capable of lasting more than a few years?

1 out of 1 people think this is helpful.
10

My 97 Mercury Grand Marquis the windshield wipers are stuck in the up position and I didn't see the answer for this question here so please if you guys know the answer let me know what you. If any one here has this answer please email me spingle41mg@gmail.com fill free email me the answer anytime

1 out of 1 people think this is helpful.
20

I have a 2003 Mercury Marauder and the wipers started acting funny a few months ago. Sometimes they would work but wouldn't turn off other times they would turn on by themselves and near the end of the problem time with them they just wouldn't work if the car was running for a few minutes. At it happens a few weeks after the wipers started acting up the lights started up. They would turn on and off on their own and the only thing I could do was to turn them on all the time. I took the car in for the 14N01 recall and had the LCM replaced. Now not only are the lights working but also my wipers are just fine too. Not saying this will cure all ills but it did fix mine.

2 out of 2 people think this is helpful.
10

How do I fix this I have a 2001 grand marquise my wipers work on high and turn signals don't work on the dash or in the back??

1 out of 1 people think this is helpful.

kbro i have 02 marquis windshield wipers only works on high and also my auto lights does not come on at all, i ca turn the headlights on manually only. and ideas for me, i do have hpp version.

Front wipers work on high speed only. Washer worked fine. The fix: Replaced the Multi Function Switch. Dealer charged $250 parts and labor. Works great now. 2011 Buick Enclave 40,000 miles.

Your Answer

Add photo

Related Questions

  • how to adjust stop position on windshield wipes 1 answer

    how to adjust final stop on windshield wipers

    Mercury Grand Marquis

    -

    Maintenance & Repair

  • Windshield wipers stuck in up position 1 answer

    The wipers were working fine and made a loud pop and after that when you turn them off they are stuck in the up position. I can't pull them off the shaft and reposition them because when you turn ...

    1993 Mercury Grand Marquis 4 Dr LS Sedan

    -

    Maintenance & Repair

  • windshield wipers froze and now will not work. 2 answers

    After a 2 inch snowfall, we atarted the car and tried the wipers but they did not work. Upon inspection, the base end od the nlade where it comes from the firewall had 2 inches of ice. After we clea...

    2006 Mercury Grand Marquis

    -

    Maintenance & Repair

  • Windshield wipers only work on high and don't retract. 2 answers

    Windshield wipers were only working on high. I replaced the motor and they worked fine for about a week and then the slowest speeds slowly quit working and now it is back to only high and stops anywh...

    1998 Mercury Grand Marquis 4 Dr LS Sedan

    -

    Maintenance & Repair

  • Windshield Wiper Switch 2 answers

    My 2000 Cougar's windshield wipers only work in the fast position. Any suggestions on if this would be a switch or motor problem?

    2000 Mercury Cougar 2 Dr V6 Hatchback

    -

    Maintenance & Repair

Grand Marquis

Looking for a Used Grand Marquis in your area?

CarGurus has 2,206 nationwide Grand Marquis listings starting at $1,995.

ZIP:

Search Mercury Grand Marquis Questions

UK Questions

Are you a UK consumer? CarGurus now has a discussion forum in the UK.

Mercury Grand Marquis Experts

#1 Tracy Hooks
Tracy Hooks
Reputation 5,030
#2 kbro
kbro
Reputation 2,020
#3 Js08016
Js08016
Reputation 1,560
View All

Related Models For Sale

Used Lincoln Town Car
38 Great Deals out of 2,159 listings starting at $1,995
Used Ford Crown Victoria
4 Great Deals out of 1,477 listings starting at $2,900
Used Chevrolet Impala
936 Great Deals out of 35,462 listings starting at $1,995
Used Mercury Marauder
44 listings starting at $3,200
Used Ford F-150
3,220 Great Deals out of 205,083 listings starting at $1,779
Used Chrysler 300
499 Great Deals out of 22,254 listings starting at $1,000
Used Toyota Camry
1,199 Great Deals out of 93,146 listings starting at $700
Used Cadillac DeVille
4 Great Deals out of 1,990 listings starting at $1,600
Used Chevrolet Tahoe
851 Great Deals out of 28,365 listings starting at $1,700
Used Buick LeSabre
8 Great Deals out of 2,328 listings starting at $1,768
Used Honda Accord
1,084 Great Deals out of 76,819 listings starting at $1,395
Used Chevrolet Silverado 1500
2,745 Great Deals out of 149,122 listings starting at $1,500

Used Cars For Sale

2011 Mercury Grand Marquis For Sale
42 listings starting at $5,900
2010 Mercury Grand Marquis For Sale
6 Great Deals out of 120 listings starting at $2,999
2009 Mercury Grand Marquis For Sale
5 Great Deals out of 117 listings starting at $2,995
2008 Mercury Grand Marquis For Sale
8 Great Deals out of 176 listings starting at $2,995
2007 Mercury Grand Marquis For Sale
6 Great Deals out of 164 listings starting at $2,750