Gauges not working on 97 Town car

Asked by Feb 18, 2016 at 07:05 PM about the 1997 Lincoln Town Car Signature

Question type: Maintenance & Repair

Temperature gauge not working after
changing thermostat and both temp
sensors in the engine compartment and
the speedometer works half the time-are
they related to the same problem?

2 Answers

5,915

check the ground to where the gauges are mounted...in fact the whole chassis must be ground-deprived...please check the strength of the ground~ find necessary measures to make that happen~

5,915

such as a jumper wire from the backside to the firewall~

Your Answer

Lincoln Town Car Experts

  • #1
    Tracy Hooks
    Reputation
    1,740
  • #1
    Tom Demyan
    Reputation
    1,740
  • #3
    tennisshoes
    Reputation
    1,280
View All

Related Models For Sale

Used Mercury Grand Marquis
24 Great Deals out of 1,677 listings starting at $800
Used Lincoln Continental
15 Great Deals out of 3,426 listings starting at $32,794
Used Ford Crown Victoria
938 listings starting at $1,496
Used Lincoln Navigator
84 Great Deals out of 3,772 listings starting at $1,795
Used Cadillac DeVille
6 Great Deals out of 1,479 listings starting at $1,999
Used Ford F-150
3,307 Great Deals out of 224,483 listings starting at $1,200
Used Mercedes-Benz S-Class
154 Great Deals out of 8,072 listings starting at $1,200
Used Ford Mustang
599 Great Deals out of 39,965 listings starting at $1,895
Used Chevrolet Impala
578 Great Deals out of 34,503 listings starting at $1,100
Used BMW 7 Series
127 Great Deals out of 5,196 listings starting at $1,750

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.