Gauges not working on 97 Town car

Asked by Feb 18, 2016 at 07:05 PM about the 1997 Lincoln Town Car Signature

Question type: Maintenance & Repair

Temperature gauge not working after
changing thermostat and both temp
sensors in the engine compartment and
the speedometer works half the time-are
they related to the same problem?

2 Answers

6,035

check the ground to where the gauges are mounted...in fact the whole chassis must be ground-deprived...please check the strength of the ground~ find necessary measures to make that happen~

6,035

such as a jumper wire from the backside to the firewall~

Your Answer

Lincoln Town Car Experts

  • #1
    Tom Demyan
    Reputation
    1,820
  • #2
    Tracy Hooks
    Reputation
    1,790
  • #3
    tennisshoes
    Reputation
    1,310
View All

Related Models For Sale

Used Mercury Grand Marquis
14 Great Deals out of 1,536 listings starting at $995
Used Lincoln Continental
15 Great Deals out of 2,820 listings starting at $25,900
Used Ford Crown Victoria
873 listings starting at $2,000
Used Cadillac DeVille
1,411 listings starting at $1,899
Used Lincoln Navigator
93 Great Deals out of 3,624 listings starting at $2,900
Used Chevrolet Impala
502 Great Deals out of 32,213 listings starting at $1,000
Used Ford F-150
3,018 Great Deals out of 230,432 listings starting at $1,300
Used Chevrolet Corvette
124 Great Deals out of 16,132 listings starting at $3,995
Used Chevrolet Tahoe
818 Great Deals out of 39,942 listings starting at $1,900
Used Mercedes-Benz S-Class
115 Great Deals out of 7,448 listings starting at $1,200

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.