Is the alternator fuse supposed to have a wire attached?

Asked by Sep 29, 2012 at 01:00 PM about the 1995 Lexus SC 400 RWD

Question type: Maintenance & Repair

My car alternator isn't charging my battery. In the fuse box (under the hood) there is no wire under the
150A alt fuse. But there are wires attached to the other fuses next to it. I smelled something burning
under the hood earlier that day before the battery died. Got a new battery and that died after an hour
drive.

1 Answer

7,325

Yes. There is supposed to be wires to the fuse. That is how it gets power. Did you smell the burn when the car was running? It is very odd. Please try to get a better description of what wires you are talking about. The wires that supply voltage to the fuse? Your voltage distributor could be malfunctioning.

Your Answer:

Lexus SC 400 Experts

  • #1
    Tom Demyan
    Reputation
    70
  • #1
    Mick Ireland
    Reputation
    70
  • #1
    Russell Murray
    Reputation
    70
View All

Related Models For Sale

Used Lexus SC 300
26 listings
Used Lexus LS 400
163 listings starting at $2,800
Used BMW 3 Series
867 Great Deals out of 31,428 listings starting at $1,250
Used Chevrolet Camaro
233 Great Deals out of 27,354 listings starting at $2,077
Used Nissan 300ZX
130 listings starting at $4,500
Used Toyota Supra
55 listings
Used Lexus GS 300
9 Great Deals out of 529 listings starting at $3,950
Used Chevrolet Corvette
86 Great Deals out of 15,056 listings starting at $3,620
Used Ford Mustang
260 Great Deals out of 37,872 listings starting at $1,350

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.