I had a new battery installed and the car (2003 es300) will start, but won't idle. The car runs great with my foot on the gas pedle, but when I take it off the car quits. Thanks

Asked by Jul 03, 2014 at 08:01 PM about the 2003 Lexus ES 300 Base

Question type: Maintenance & Repair

1 Answer

246,235

Was it doing this before you replaced the battery? Sound like a Throttle position sensor issue. Any light lit up on the dash? Did you check fuel pressure?

1 of 1 people found this helpful.

Your Answer

Add photo

Related Questions

Search Lexus ES 300 Questions

Lexus ES 300 Experts

#1 Tom Demyan
Tom Demyan
Reputation 1,320
#2 rockajean
rockajean
Reputation 460
#3 Scott Vetter
Scott Vetter
Reputation 410
View All

Related Models For Sale

Used Lexus ES 330
40 Great Deals out of 1,083 listings starting at $2,495
Used Toyota Camry
1,219 Great Deals out of 84,969 listings starting at $750
Used Lexus GS 300
29 Great Deals out of 732 listings starting at $1,499
Used Honda Accord
1,046 Great Deals out of 68,867 listings starting at $1,000
Used Lexus IS 300
19 Great Deals out of 2,656 listings starting at $2,588
Used Toyota Avalon
235 Great Deals out of 14,291 listings starting at $1,149
Used Lexus LS 430
32 Great Deals out of 883 listings starting at $2,910

Used Cars For Sale

2003 Lexus ES 300 Base For Sale
10 Great Deals out of 267 listings starting at $2,885
2002 Lexus ES 300 Base For Sale
11 Great Deals out of 234 listings starting at $1,495

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.