Has anyone had problems with after-market 02 Sensors for the 99 Lexus ES300. I have changed the one on the front of the moter near radiator at least 6-8 times with 3 diff ones. Still code 1133


Asked by Apr 07, 2016 at 10:29 AM about the 1999 Lexus ES 300 FWD

Question type: Maintenance & Repair

Code P1133 has been coming back for over 6 months now.  I purchased what they told me was an OEM 02 Sensor.  I have 3 total for the one that is at the front of the motor near radiator, in exhaust pipe.  When I go back to the original sensor, the car runs rough, and codes rather quickly.  I've heard I should by the Bosch 02 sensor, or get one from Toyota.  Any help would be appreciated immensely.

1 Answer


I had the same code on our Lexus, tried aftermarket sensor, worked about a week light came back on, checked the wiring could not find ant problem there, replaced the sensor again still using aftermarket, lasted another week, light came back on, purchased a sensor from the dealer and installed it, ran fine no more check engine light. Was still running great right up to the wreck.

Your Answer

Lexus ES 300 Experts

  • #1
    Tom Demyan
  • #2
  • #3
View All

Related Models For Sale

Used Lexus GS 300
14 Great Deals out of 573 listings starting at $2,799
Used Toyota Camry
802 Great Deals out of 70,728 listings starting at $1,112
Used Honda Accord
539 Great Deals out of 91,748 listings starting at $1,495
Used Lexus RX 300
13 Great Deals out of 709 listings starting at $2,475
Used Toyota Avalon
156 Great Deals out of 9,581 listings starting at $1,995
Used Lexus LS 400
146 listings starting at $2,450

Used Cars For Sale

2003 Lexus ES 300 FWD For Sale
166 listings starting at $2,999
2002 Lexus ES 300 FWD For Sale
5 Great Deals out of 170 listings starting at $2,000

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.