heater and signal lights not working

Asked by Dec 28, 2012 at 04:46 PM about the 1990 Ford Tempo 4 Dr GL Sedan

Question type: General

When I start my car the heater does not blow air and the signal lights do not work?  Is that some type of
fuse needed

3 Answers

251,135

It's a worn ignition switch. Remove the lower plastic piece between the steering wheel and the dash and you should see a rectangular white plastic plug connected to a metal one the same size. This gets worn and loose. Wiggle it around some and see if you can get your turn signals to work.

4 of 4 people found this helpful.

Thanks your answer is very helpfull!! Liz

Thanks I know this is it because I had a key get stuck in switch took apart the plastic and that plug just fell in the floorboard thanks

Your Answer

Tempo

Looking for a Used Tempo in your area?

CarGurus has 9 nationwide Tempo listings and the tools to find you a great deal.

ZIP:

Ford Tempo Experts

  • #1
    Tom Demyan
    Reputation
    200
  • #2
    tennisshoes
    Reputation
    190
  • #3
    Reelin68
    Reputation
    160
View All

Related Models For Sale

Used Ford Taurus
248 Great Deals out of 17,805 listings starting at $1,499
Used Ford Bronco
177 listings
Used Ford F-150
2,234 Great Deals out of 183,030 listings starting at $1,500
Used Ford Escort
316 listings
Used Toyota Corolla
925 Great Deals out of 66,685 listings starting at $1,000

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.