I have a 1990 bronco with a 300 straight 6 .. I put in a new water pump an thermostat and it is still getting hot why is that

Asked by Feb 27, 2015 at 05:30 PM about the 1990 Ford Bronco Custom 4WD

Question type: General

Well I was going out for a drive an it started to get hot so I had put a new thermostat in an
it still did it so I put a low number thermostat in and it still did it ...so I got a new water
pump an put it in anit is still doing it why is that... Can u help me

1 Answer

55,435

Could be a plugged radiator. Always use the recommended thermostat temperature. Lower is usually not better or even a good idea.

Your Answer

Ford Bronco Experts

  • #1
    tennisshoes
    Reputation
    450
  • #2
    Js08016
    Reputation
    170
  • #2
    Clayton Cameron
    Reputation
    170
View All

Related Models For Sale

Used Ford F-150
3,215 Great Deals out of 223,768 listings starting at $1,200
Used Ford Mustang
578 Great Deals out of 39,801 listings starting at $1,895
Used Chevrolet Blazer
6 Great Deals out of 931 listings starting at $950
Used Jeep Wrangler
500 Great Deals out of 19,452 listings starting at $1,999
Used Ford F-250
448 listings starting at $2,500
Used Ford Explorer
1,225 Great Deals out of 69,677 listings starting at $1,000
Used Ford Ranger
191 Great Deals out of 5,554 listings starting at $995
Used Chevrolet Camaro
442 Great Deals out of 31,710 listings starting at $1,450
Used Toyota 4Runner
332 Great Deals out of 26,862 listings starting at $1,800

Used Cars For Sale

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.