right front signal light works sometimes then when i turn the ignition off and try the right signal again it dont work again.

Asked by Oct 06, 2014 at 02:56 PM about the 1990 Chrysler Le Baron GT Coupe

Question type: Maintenance & Repair

I have change the flasher and a different signal switch still have the same problem.Does anyone know what the problem could be?

1 Answer

12,155

check the plug at the light for corrosion. when a car gets older it tends to get a lot of corrosion in the back of the plug and can cause a bad connection. also check your wire as far as you can trace it back from the light. check for britle parts in the casing and tape them if you find them. you may have to replace the wiring back a ways if its bad enough

1 people found this helpful.

Your Answer

Chrysler Le Baron Experts

  • #1
    dandyoun
    Reputation
    320
  • #2
    chassy
    Reputation
    220
  • #3
    TopShadeTree
    Reputation
    180
View All

Related Models For Sale

Used Chevrolet Camaro
242 Great Deals out of 28,774 listings starting at $1,800
Used Ford Mustang
251 Great Deals out of 36,708 listings starting at $2,500
Used Chevrolet Corvette
98 Great Deals out of 15,357 listings starting at $3,900
Used Toyota Camry
789 Great Deals out of 70,435 listings starting at $1,000
Used Mitsubishi 3000GT
68 listings starting at $3,995
Used Mazda MX-5 Miata
33 Great Deals out of 4,707 listings starting at $2,275
Used Porsche 911
71 Great Deals out of 4,974 listings starting at $12,495
Used Volkswagen Jetta
401 Great Deals out of 24,866 listings starting at $1,800
Used Ford F-150
2,303 Great Deals out of 215,007 listings starting at $1,300

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.