working on all speeds defrost is not blowing

fscalise65
20

Asked by Jun 25, 2013 at 04:00 PM about the 2005 Ford Five Hundred SEL

Question type: Maintenance & Repair

1 Answer

recheck blower wheel, might be slipping on shaft,this is not a common problem with that model

Your Answer

Add photo

Related Questions

Search Ford Five Hundred Questions

Ford Five Hundred Experts

#1 FordNut
FordNut
Reputation 640
#2 jonnyboii
jonnyboii
Reputation 580
#3 dvigano
dvigano
Reputation 530
View All

Related Models For Sale

Used Ford Taurus"
343 Great Deals out of 21,617 listings starting at $1,499
Used Ford Fusion"
1,257 Great Deals out of 75,993 listings starting at $800
Used Chevrolet Impala"
867 Great Deals out of 32,991 listings starting at $1,300
Used Mercury Montego"
13 Great Deals out of 398 listings starting at $1,995
Used Chevrolet Malibu"
1,128 Great Deals out of 66,182 listings starting at $695
Used Honda Accord"
1,274 Great Deals out of 75,399 listings starting at $995
Used Ford Escape"
1,391 Great Deals out of 90,797 listings starting at $500
Used Toyota Camry"
1,584 Great Deals out of 94,957 listings starting at $995
Used Ford Focus"
989 Great Deals out of 58,756 listings starting at $995
Used Ford F-150"
2,919 Great Deals out of 201,714 listings starting at $1,500
Used Nissan Altima"
1,585 Great Deals out of 82,424 listings starting at $695
Used Buick LaCrosse"
345 Great Deals out of 15,363 listings starting at $1,200
Used Ford Mustang"
777 Great Deals out of 40,174 listings starting at $1,450
Used Mercury Sable"
4 Great Deals out of 1,333 listings starting at $1,495