i have a 2005 ford five hundred sel when i have the air conditioning on high the engine lags when i accelerate why is that?

25

Asked by May 25, 2011 at 03:20 AM about the 2005 Ford Five Hundred SEL

Question type: Maintenance & Repair

1 Answer

5

Possibly the transmission is getting the wrong signal, The trans is normally going to go to the most effecient setting of power for best ecomony.

Your Answer

Add photo

Related Questions

Search Ford Five Hundred Questions

Ford Five Hundred Experts

#1 jonnyboii
jonnyboii
Reputation 640
#2 Tom Demyan
Tom Demyan
Reputation 580
#3 dvigano
dvigano
Reputation 560
View All

Related Models For Sale

Used Ford Taurus
249 Great Deals out of 20,433 listings starting at $699
Used Ford Fusion
1,120 Great Deals out of 83,259 listings starting at $998
Used Ford Explorer
944 Great Deals out of 72,519 listings starting at $1,000
Used Chevrolet Impala
521 Great Deals out of 31,725 listings starting at $1,450
Used Chevrolet Malibu
950 Great Deals out of 79,654 listings starting at $1,500
Used Ford F-150
2,194 Great Deals out of 206,316 listings starting at $1,499
Used Ford Mustang
472 Great Deals out of 45,735 listings starting at $1,999
Used Ford Focus
546 Great Deals out of 57,171 listings starting at $1,095
Used Honda Accord
813 Great Deals out of 84,287 listings starting at $1,050
Used Dodge Charger
407 Great Deals out of 28,172 listings starting at $1,988
Used Toyota Camry
1,011 Great Deals out of 90,917 listings starting at $650
Used Nissan Altima
1,033 Great Deals out of 81,564 listings starting at $1,200
Used Mercury Montego
305 listings starting at $2,300
Used Honda Civic
656 Great Deals out of 88,603 listings starting at $995

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.