My 2005 Ford Five hundred ran hot today and my heater blows cold ....recently changed water pump and thermostat ...I also flushed the radiator.... Possible problem??

Asked by Feb 01, 2015 at 09:35 PM about the 2005 Ford Five Hundred Limited

Question type: Maintenance & Repair

1 Answer

56,715

Check the antifreeze level. It may be low. Also check for leaks. By flushing out the system you may have opened up a weak spot in the cooling system. This is especially true if a chemical cleaner was used. HTH. -Jim

Your Answer

Add photo

Related Questions

Search Ford Five Hundred Questions

Ford Five Hundred Experts

#1 FordNut
FordNut
Reputation 690
#2 jonnyboii
jonnyboii
Reputation 600
#3 dvigano
dvigano
Reputation 540
View All

Related Models For Sale

Used Ford Taurus
344 Great Deals out of 21,442 listings starting at $1,499
Used Ford Fusion
1,132 Great Deals out of 71,255 listings starting at $1,295
Used Ford Focus
1,112 Great Deals out of 57,192 listings starting at $1,395
Used Mercury Montego
11 Great Deals out of 312 listings starting at $1,499
Used Ford F-150
3,132 Great Deals out of 200,437 listings starting at $1,273
Used Ford Mustang
640 Great Deals out of 36,930 listings starting at $2,800
Used Honda Accord
1,078 Great Deals out of 74,908 listings starting at $969
Used Chevrolet Impala
846 Great Deals out of 34,369 listings starting at $1,800
Used Chrysler 300
462 Great Deals out of 19,778 listings starting at $1,750
Used Ford Explorer
1,347 Great Deals out of 70,738 listings starting at $985
Used Chevrolet Malibu
1,011 Great Deals out of 77,144 listings starting at $2,795
Used Hyundai Sonata
889 Great Deals out of 48,408 listings starting at $1,000
Used Ford Escape
1,581 Great Deals out of 83,423 listings starting at $1,499
Used Dodge Charger
496 Great Deals out of 27,801 listings starting at $2,343
Used Toyota Camry
1,288 Great Deals out of 96,921 listings starting at $999