My 2005 Ford Five hundred ran hot today and my heater blows cold ....recently changed water pump and thermostat ...I also flushed the radiator.... Possible problem??

Asked by Feb 01, 2015 at 09:35 PM about the 2005 Ford Five Hundred Limited

Question type: Maintenance & Repair

1 Answer

60,935

Check the antifreeze level. It may be low. Also check for leaks. By flushing out the system you may have opened up a weak spot in the cooling system. This is especially true if a chemical cleaner was used. HTH. -Jim

Your Answer

Add photo

Related Questions

Search Ford Five Hundred Questions

Ford Five Hundred Experts

#1 FordNut
FordNut
Reputation 700
#2 jonnyboii
jonnyboii
Reputation 640
#3 dvigano
dvigano
Reputation 560
View All

Related Models For Sale

Used Ford Taurus
253 Great Deals out of 20,518 listings starting at $1,500
Used Ford Fusion
1,060 Great Deals out of 78,462 listings starting at $1,250
Used Chevrolet Impala
793 Great Deals out of 34,401 listings starting at $799
Used Ford Focus
696 Great Deals out of 58,725 listings starting at $995
Used Ford Explorer
937 Great Deals out of 74,004 listings starting at $750
Used Chevrolet Malibu
1,008 Great Deals out of 85,694 listings starting at $1,995
Used Ford Escape
1,119 Great Deals out of 90,859 listings starting at $1,295
Used Mercury Montego
7 Great Deals out of 370 listings starting at $1,999
Used Honda Accord
812 Great Deals out of 81,611 listings starting at $899
Used Nissan Maxima
347 Great Deals out of 25,224 listings starting at $1,400
Used Nissan Altima
1,079 Great Deals out of 82,567 listings starting at $670
Used Ford F-150
2,692 Great Deals out of 212,369 listings starting at $1,000
Used Toyota Camry
1,096 Great Deals out of 96,274 listings starting at $1,250
Used Chrysler 300
404 Great Deals out of 22,159 listings starting at $1,000
Used Ford Freestyle
4 Great Deals out of 725 listings starting at $2,499