I have a 93 ford tempo gl I was messing with the amp in the the trunk and the power cable hit the metal. In thr trunk my car was on when I was doing this and everything shit off now it won't crank

Asked by Jul 25, 2015 at 12:14 AM about the 1993 Ford Tempo 4 Dr GL Sedan

Question type: Maintenance & Repair

I replaced the battery checked all my fuses
and it's all fine but the car still won't start

1 Answer

104,275

You may have blown you fusible link.

Your Answer

Add photo

Related Questions

Search Ford Tempo Questions

Ford Tempo Experts

#1 Tom Demyan
Tom Demyan
Reputation 200
#2 tennisshoes
tennisshoes
Reputation 180
#3 littlehorn
littlehorn
Reputation 140
View All

Related Models For Sale

Used Ford Taurus
282 Great Deals out of 20,502 listings starting at $1,300
Used Nissan Quest
70 Great Deals out of 2,794 listings starting at $2,499
Used BMW 3 Series
961 Great Deals out of 30,762 listings starting at $1,000
Used Jeep Cherokee
494 Great Deals out of 42,390 listings starting at $1,995
Used Ford Crown Victoria
14 Great Deals out of 1,278 listings starting at $1,988
Used Chevrolet Cavalier
3 Great Deals out of 1,006 listings starting at $695
Used Pontiac Grand Am
1,169 listings starting at $1,000
Used Ford Escort
331 listings
Used Ford Explorer
1,004 Great Deals out of 70,331 listings starting at $997

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.