I have a 99 Chevy Monte Carlo and I just replaced the fuel pump the other day. Since I got the car restarted it runs good but when I mash the gas down to really get up speed it hesitates & sputters.

Asked by May 14, 2015 at 11:58 AM about the 1999 Chevrolet Monte Carlo 2 Dr Z34 Coupe

Question type: Maintenance & Repair

What could be causing this?

1 Answer

115,775

Did you replace the fuel filter also? If you did then you may have a fuel pressure regulator going bad or the fuel pump is not making enough pressure even though it is new. Test the fuel pressure and flow rate. You may want to reset the ECM after everything is done.

Your Answer:

Chevrolet Monte Carlo Experts

  • #1
    Js08016
    Reputation
    600
  • #2
    Tom Demyan
    Reputation
    550
  • #3
    John Saffrahn
    Reputation
    490
View All

Related Models For Sale

Used Chevrolet Impala
448 Great Deals out of 25,776 listings starting at $950
Used Chevrolet Camaro
232 Great Deals out of 27,541 listings starting at $2,800
Used Ford Mustang
273 Great Deals out of 37,795 listings starting at $1,350
Used Chevrolet Corvette
83 Great Deals out of 15,126 listings starting at $3,620
Used Pontiac Grand Prix
8 Great Deals out of 1,771 listings starting at $800
Used Buick Regal
83 Great Deals out of 4,008 listings starting at $5,300
Used Chevrolet Malibu
465 Great Deals out of 51,838 listings starting at $1,975
Used Chevrolet Silverado 1500
1,803 Great Deals out of 154,112 listings starting at $1,000
Used Chevrolet Tahoe
523 Great Deals out of 37,969 listings starting at $1,250
Used Pontiac Firebird
6 Great Deals out of 667 listings starting at $4,700

Used Cars For Sale

2007 Chevrolet Monte Carlo For Sale
87 listings starting at $7,195
2006 Chevrolet Monte Carlo For Sale
116 listings starting at $3,498

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.