Gas gauge not working & car starting in neutral since having timing chain replaced-related?


Asked by Jun 10, 2015 at 09:38 AM

Question type: Maintenance & Repair

I have a 2008 Suzuki XL7 w/ about 135K miles on in. I recently had to have my timing
chain replaced. I picked my car up from the mechanic about a week ago. Since I
picked it up my gas tank says it's empty even when it's not. The first day I picked it up
I filled it up & the gauge slowly went to full but then went back to empty & has been on
empty ever since. Yesterday morning I tried to start my car to go to work & it wouldn't
crank at all (radio & headlights were both on). I fot a ride to work & called the
mechanic about it. He told me to try to start my car in neutral - I tried that & it worked.
I turned it off & then started it back in park. This morning it would only start in neutral.
Are either of these problems connected at all to the timing chain?

1 Answer


No the timing chain has nothing to do with either of those problems. The fuel gauge problem may have something to do with the float in the gas tank and the no starting sound like you have a bad neutral safety switch. Switch is not sensing that vehicle is in park allowing it to start. Some switches can be adjusted. So I think what we have here is a case of a word in which I can not think of right now but something that just happens at the same time as something else.

Your Answer

Add photo

Related Questions

Search Suzuki Questions

Suzuki Experts

#1 Peer
Reputation 860
#2 Tom Demyan
Tom Demyan
Reputation 770
#3 Sheila Tharp
Sheila Tharp
Reputation 350
View All