installed new fuel pump,old one had 35 psi,new one now 3 weeks later is 38 psi,fuel filter is good,replaced pump relay too,it goes to very low idle at times has had miss fire on #2 cyl #6cly #8cyl..

Asked by Aug 27, 2010 at 06:28 PM

Question type: Maintenance & Repair

3 Answers

7,025

fuel system is good now.. pressure is up to specs. timing chain or ignition module could be the next things to check. any crossed wires(correct firing order) ? wires to the ignition module kept clear of sparkplug wires? how many miles on engine?

sounds like a you need a new cap and rotor i had the same problem a month ago i changed everything fuel pump filter crank sensor spark plugs wires everything i could think of turns out it was the cap and rotor... that is if you have an lt1its a fun job...

55

Sounds like an Opti Spark going bad....fun job have to pull water pump and some other misc parts off longer job but not hard make sure to mark which plugs goto which cyclinder...

Your Answer

Add photo

Related Questions

Pontiac

Looking for a Used Pontiac in your area?

CarGurus has 14,134 nationwide Pontiac listings starting at $699.

ZIP:

Search Pontiac Questions

Pontiac Experts

#1 tenspeed
tenspeed
Reputation 11,240
#2 Tom Demyan
Tom Demyan
Reputation 8,730
#3 Js08016
Js08016
Reputation 8,030
View All

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.