I just had my Nissan 300zx 86 out of the shop. I have been starting the car every 2 weeks or monthly. Now the car needs a jump and after running it 15 minutes. I shut it off and it doesn't start. All the lights go on and it has a clicking sound. HELP me my boyfriend is not going to put another penny in it. You have helped me out in the past with the sterring module when it blew out. After I bought an ECU that was not needed. AS I stated that cost $800. I'm trying to get this car registered waiting for the titlte. Or sell it.

Asked by Oct 07, 2012 at 01:17 PM

Question type: Maintenance & Repair

My car won't start after jumping it. When I turn it off and try and try it all the lights go on. But gives me a clicking sound.  I just had this car in and it's been sitting a few months on and off I would start it.

1 Answer

405

It suggests a battery Laura, or possibly your alternator. The first thing I would do is chack the battery acid levels if you can pop the caps off. If the cells are low or any plates are exposed replace the battery. I don't know if you can do it with your car but a quick check for the alternator is to loosen the negative terminal for the battery, start the vehicle and pull the terminal off the battery. If the car stalls than you most likely need an alernator. Please check to see if pulling the terminal from the battery will be safe for your vehicle. The alternator supplies power your engine needs to run and also recharges the battery.

1 out of 1 people think this is helpful.

Your Answer

Add photo

Related Questions

Search Nissan Questions

Nissan Experts

#1 Tom Demyan
Tom Demyan
Reputation 6,480
#2 FordNut
FordNut
Reputation 4,650
#3 Robert Lavallee
Robert Lavallee
Reputation 3,660
View All