Have a 1986 Ford Escort Wagon. 1.9 liter engine, 4 cyclinder, 5 speed manual. Starts fine but once it has warmed up it dies. Won't start again until it cools down. Can anyone help me out in this?

Asked by Jun 28, 2016 at 07:02 PM

Question type: Maintenance & Repair

2 Answers

19,235

hows the fuel filter??? had to ask.

Good, just replaced.

Your Answer

Add photo

Related Questions

  • i have a 94 ford escort wagon 1.9 L engine and the car wont accelerate. 2 answers

    I had a used engine put in because of a blown head gasket. Then it didn't want to start every time so I put a new battery in and a new fuel pump. Now when I turn it on the check engine light is on...

    1994 Ford Escort 4 Dr LX Wagon

    -

    Maintenance & Repair

  • 1998 Ford Escort 2.0 engine problem 17 answers

    I have a 1998 Ford Escort 2.0 engine it runs fine when its cold, but when it warms up it dies at idle. Above idle it runs great. How can I fix this?

    1998 Ford Escort

    -

    Maintenance & Repair

  • how to fix a rough idling 1.9 litter ford engine in a 93 escort lx 5 answers

    i replaced the motor in my escort with one from a 96, also replaced plugs. alt., plug wires injectors, timing belt, serptine belt, tensioner, fuel filter,temp sensor, cooling fan switch, but as soon...

    1993 Ford Escort 4 Dr LX Wagon

    -

    Maintenance & Repair

  • 1986 Camaro 5.0l 305ci 5 speed manual: Gets too much fuel, not sure why. 1 answer

    Alright, so provided there's no character limit on these questions, this is probably gonna be a book, so bear with me! About a month ago, I was driving home from school at about 3:30 on a dry, sunny...

    1986 Chevrolet Camaro Base

    -

    Maintenance & Repair

Shortcuts

Search Maintenance & Repair Questions

Maintenance & Repair Experts

#1 Tom Demyan
Tom Demyan
Reputation 150,450
#2 FordNut
FordNut
Reputation 103,280
#3 dandyoun
dandyoun
Reputation 84,290
View All