Asked by Apr 17, 2016 at 07:44 PM

Question type: Maintenance & Repair

Hi;first of all thanks for all the help in this
website.I heaved read and done
everything to my 2005 chevy express
2500 4.8,changed sending unit and
nothing so i flush the engine twice no
results,removed oil pan clean everything
including  the pickup tube and  the 0
ring,moved up to replace the oil pump
and put everything back together,look for
the filter under the OPSU it didn't have
one,got a new OPSU before i put it in
intake  i connect the wires turn on the
key and apply pneumatic pressure to the
OPSU and my pressure gauge work fine,
and i also change the oil level
sensor,switch ACdelco to Bosch oil
filter,fill up with fresh mobil 1 start the
truck and sounds really good,no nuking
no shaking BUT GUESS WHAT no oil
pressure PLEASE HELP!!!!!

2 Answers


the oil pump is at the bottom of the oil pan~ ....guess the shaft could break...inspect, if you need to drop the pan and install a new gasket to do so...but I think that you need to inspect your oil pump...I can remember I installed a "heavy duty" oil pump on my Impala 400 rebuild and was faced with all kinds of oil fact there is a spring inside the pump so as NOT to put too much pressure out there....YES...check that pump...need to put a new gasket on the pan ....when you do~ report back with your success~


Best Answer

Your Answer

Add photo

Related Questions


Search Maintenance & Repair Questions

Maintenance & Repair Experts

#1 Tom Demyan
Tom Demyan
Reputation 145,760
#2 FordNut
Reputation 100,770
#3 dandyoun
Reputation 82,410
View All