2019 Ford Expedition el

Asked by Apr 01, 2016 at 11:01 PM

Question type: Maintenance & Repair

My expedition has started to have ac issues. It blows cold
when you start off, then if you stop at a light it gets warm,
does not stay cold. Over and over again.  What could be
the issue?

5 Answers

1,730

Have you checked freon. Does compressor kick on and off,it shouldn't. If you add, make sure you put in dye to than b able to check for leaks

1 of 1 people found this helpful.

I have not checked the freon yet, but I will asap. I figured since it got cold at all the freon level would be ok. And I think there are two systems to check, a front and rear. Is this true on a 2010 Ford Expedition EL. Thank you in advance for any input.

No the compressor does not seem to be kicking on and off, which I thought was another sign of low freon, but will verify today.

247,175

Could be low on refrigerant, fan not working or an expansion valve. Take the truck to a shop that can check the high and low pressures on the system, and properly charge it and fix the leaks like Milbek mentioned.

1 of 1 people found this helpful.

Thank you. I sure hope its a refrigerant issue it does have 110,000 miles on it but runs like all Fords do, like the wind! Thanks again.

Your Answer

Add photo

Related Questions

  • 2019 Ford Expedition el 5 answers

    My expedition has started to have ac issues. It blows cold when you start off, then if you stop at a light it gets warm, does not stay cold. Over and over again. What could be the issue?

    Maintenance & Repair

  • My 2003 Ford Expedition 2 answers

    My 03 expedition only turns on when I spray starter fluid but turns off immediately. .... has anyone had this problem?

    2003 Ford Expedition XLT

    -

    Maintenance & Repair

  • My 2003 Ford Expedition 4 answers

    Hello Everyone.. my 03 expedition the battery is not charging and if does it dies asap I just put in a new battery, alternator, fuel pump and changed the corroded plugs. What can this be?? Please h...

    2003 Ford Expedition Eddie Bauer 4WD

    -

    Maintenance & Repair

  • Ford Expedition won't start! 5 answers

    I am praying someone out there can help me, my vehicle has been down for a year now and I have had some recent changes that make it imperative I get my vehicle running! So, i have a 2000 Ford Exp...

    2000 Ford Expedition Eddie Bauer 4WD

    -

    Maintenance & Repair

  • 2000 Ford Expedition Vibration 5 answers

    OK guys... Here goes. 2000 A4WD Expedition Vibration... 210,000 Miles. Seems to be in the front. Details: About 10,000 Miles ago, some grinding in the front, No vibration (not the brakes).. Repla...

    2000 Ford Expedition Eddie Bauer 4WD

    -

    Maintenance & Repair

Shortcuts

Search Maintenance & Repair Questions

Maintenance & Repair Experts

#1 Tom Demyan
Tom Demyan
Reputation 175,080
#2 dandyoun
dandyoun
Reputation 93,620
#3 tennisshoes
tennisshoes
Reputation 76,150
View All

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.