Pontiac sunfire 2001

Asked by Feb 01, 2016 at 01:45 PM

Question type: Maintenance & Repair

Mixed orange and green antifreeze. ..car was
getting hot...took in to get a flush. ..fan wasn't
working got that replaced no engine flush. ..drove
one day after new fan car hot coolant not
circulating. ..water pump is fine...what else can
cause no circulating. ..shop can't figure it out as of
now

4 Answers

550

Maybe a faulty thermostat? Are you saying no circulation through the radiator or engine block? Did you flush the radiator or engine block or both? Sometimes air in the cooling system can cause problems? Maybe you need to try a different shop? How hot does the engine get in degrees F? Does the radiator fan work, now? I can only help you with testing. You have to do the actual testing.

Thank you for your answers..so far seem to been air in the engine...I had changed the thermostat twice in a year thinking the first was bad..the thermostat is on front of the engine so the engine did lose coolant thinking that is when the air got in there...and there is no radiator cap follow through the reservoir

Not sure when they flushed if they did both...I just assumed when one has their car flushed that both radiator and engine would get flushed should be the right process ..if one does a job should be done right the first time

Filled through reservoir

Your Answer

Shortcuts

Maintenance & Repair Experts

  • #1
    Tom Demyan
    Reputation
    186,070
  • #2
    dandyoun
    Reputation
    97,250
  • #3
    tennisshoes
    Reputation
    82,440
View All

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.