2000 Kia Sephia 1.8L bogs on fast throttle but fine on slow acceleration

2,295

Asked by Jan 19, 2016 at 07:59 PM

Question type: Maintenance & Repair

I have a 2000 kia in my shop that has fine throttle response when slowly
pressing down the gas but on fast throttle car bogs down. the car doesn't
die just bogs out and wont go over 1500 RPM. if I slowly press the peddle
down will rev up. thinking throttle position sensor  or fuel filter but want a
second OP. The check engine light was on but it said it was a CPS so I
replaced it. light is out now but I don't know if it had this problem before I did
the CPS.

6 Answers

68,895

Change your fuel filter.

2,295

ok I have checked it with my scanner and the TPS seems to be working right but smells like it is loading up when running

2,295

I now have a code cam and crank sensor high output bank 1

1 of 1 people found this helpful.
68,895

Sounds like your o2 sensor is bad,or your catilac converter is clogged.

2,295

would that give me a faulty cam or crank sensor code?

2,295

found the problem the crank shaft key way was broke out and at the crank a bit causing the timing to be off. the crank timing was on time but could not sink up with the cam

Your Answer

Shortcuts

Maintenance & Repair Experts

  • #1
    Tom Demyan
    Reputation
    181,800
  • #2
    dandyoun
    Reputation
    96,040
  • #3
    tennisshoes
    Reputation
    79,700
View All

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.