93 Chevy suburban transmission

Asked by Jan 10, 2016 at 11:46 PM

Question type: Maintenance & Repair

I was driving along. Let off the throttle for a
second light turned green so hit the throttle again
but no response from trans pulled over to a
parking lot tryed cooling it down ( not hot at all)
from running temps but I haven't been able to
catch any gears park works but drive 1-2 and
reverse act like neutral tryed putting it in 4H 4L no
response. Any help would be great thank you

4 Answers

515

how many miles on truck. check Transmission fluid on level surface after warming up for 5 min. and check level. any leaks?

It has a little over 214,000 on the odomater.the trans cooler line has a slight leak. when it happed I had just added fluid to it to make sure it was full because it was my dayly driver

515

hows fluid now any metal. smell burnt? still red?

Sorry it took so long to respond but fluid is red smells good and normal amount of debris on the magnet in the pan. I pulled it and the inside looks new but I'm not a transmission builder so I wouldn't know what would be bad inside

Your Answer

Shortcuts

Maintenance & Repair Experts

  • #1
    Tom Demyan
    Reputation
    182,140
  • #2
    dandyoun
    Reputation
    96,190
  • #3
    tennisshoes
    Reputation
    80,010
View All

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.