I have a 99 Durango rear axle went out! Replaced with a bone yard one. Speedo not working now. It runs and drives fine. Could it be the rear wheel speed sensor or speedometer sensor?

Todd Petersen

Asked by Sep 13, 2015 at 03:47 PM

Question type: Maintenance & Repair

1 Answer

Yes. Either/or.

Your Answer

Add photo

Related Questions

  • could the speed sensor affect the speedo to miss read and sometimes not work at all? 8 answers

    Driving and sometime the speedo reads 80 but going 30mph and then it does not work at all while driving.

    2005 Buick LeSabre Custom


    Maintenance & Repair

  • digital speedometer stuck at 0 10 answers

    i just bought a mark vii over the weekend and the speedometer is stuck at 0. I put it on a lift and checked the sensor on the tranny, which was good, and the wheel sensors on the rear drive axle, go...

    1989 Lincoln Mark VII Bill Blass


    Maintenance & Repair

  • which sensor is for the speedometer ? 22 answers

    there is 2 sensors an input and an output, one is by where the axle goes in and the other is on side of the tranny in middle of the big round disc.. i just installed a tranny and i have no speedomet...

    2002 Ford Escape XLT 4WD


    Maintenance & Repair

  • Why wont my speedometer work? 2 answers

    I have replaced both speed sensors on my 2500 dodge diesel 4x4. My speedometer is still not working. My abs light is on as well. Any ideas?

    2002 Dodge Ram 2500 4 Dr SLT 4WD Quad Cab SB


    Maintenance & Repair


Search Maintenance & Repair Questions

Maintenance & Repair Experts

#1 Tom Demyan
Tom Demyan
Reputation 146,300
#2 FordNut
Reputation 101,130
#3 dandyoun
Reputation 82,540
View All