Cooling fans are working on a 1995 lt1 trans am. I tried the jump wire and they do work. I tried to jump the ect plug no luck. What can i try next?

Asked by Jul 07, 2015 at 05:19 PM

Question type: Maintenance & Repair

1 Answer

18,510

Try replacing your coolent temperature sensor. But first check fuses and relays.

Your Answer

Add photo

Related Questions

  • My 07 chevy colorado won't start or turnover 2 answers

    It is completely dead, no noises, no lights, automatic locks wont work. Tried to give it a jump and still nothing. I checked the terminals and they seem fine. Its not extremely cold, theres fuel, and...

    2007 Chevrolet Colorado Work Truck Extended Cab 4WD

    -

    Maintenance & Repair

  • Jump starting 9 answers

    I left the interior light on for three days, now my Tucson wont start. I tried jumpimg it, but mistakenly crossed the cables and I heard a humming noise coming from the engine. As soon as I realized ...

    2009 Hyundai Tucson

    -

    Maintenance & Repair

  • My heater fan will not come on. Replace resister, fuses are good. Replaced switches. Fan works when bench tested. 1 answer

    I have tried everything. What would be the next thing?

    2000 Pontiac Grand Am SE1

    -

    Maintenance & Repair

  • Cooling fan stopped working again? 11 answers

    Okay my cooling fan wouldn't work then me and my dad replaced the fuse, the motor on the fan was good, and the new fuse didn't fix the problem. Okay so then we looked at all the wires for it, the...

    1995 Ford Escort 2 Dr LX Hatchback

    -

    Maintenance & Repair

Shortcuts

Search Maintenance & Repair Questions

Maintenance & Repair Experts

#1 Tom Demyan
Tom Demyan
Reputation 168,430
#2 dandyoun
dandyoun
Reputation 91,460
#3 tenspeed
tenspeed
Reputation 73,800
View All

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.