Chasing electronic gremlins.. I have a 1996 s10. 4.3. Changed in ignition Control module. Still won't start. Keeps blowing engine fuse.. please help. Thank you

Asked by Jun 01, 2015 at 09:44 PM

Question type: Maintenance & Repair

4 Answers

63,345

This is a hard one as you sat gremlins,but my best guess would be the starter is bad,making the fuse blow.

455

What was the original problem ?

455

Recheck your harnesses to module, you may have pinched wire. Also the module may be incorrect for that vehicle

455

Is the module inside distributor?

Your Answer

Add photo

Related Questions

  • 96 Chevy S10 Blazer with 4.3 L engine vortex will turn over but won't start. Why? 78 answers

    The RPM's fluttered and it died. The PCM code read that it was the crankshaft sensor. We have checked the following: coil - replaced fuses - good control module (ecm) - replaced plug wires - replaced...

    1996 Chevrolet Blazer 4 Door LS 4WD

    -

    Maintenance & Repair

  • Chasing an electrical problem... 8 answers

    Driving home last night, I started having weird power fluctuations. First, every time I had to slow down, the stereo cut out and the headlights and instrument panel lights dimmed. It stopped the sec...

    1997 Ford Probe GT

    -

    Maintenance & Repair

  • Electronic 1 answer

    I replaced a ecm on a 02 Ford Taurus now the engine won't turn over yet the accessories work. Please. Help

    2002 Ford Taurus SE

    -

    Maintenance & Repair

  • 1999 4.3 misfiring 40 answers

    I'm running out of ideas on a problem with my 99 S10 4.3 The truck will start and idle fine however as soon as you feed a little gas it starts to miss. Giving it even more gas is either covering up th...

    1999 Chevrolet S-10 2 Dr STD Standard Cab LB

    -

    Maintenance & Repair

Shortcuts

Search Maintenance & Repair Questions

Maintenance & Repair Experts

#1 Tom Demyan
Tom Demyan
Reputation 166,080
#2 dandyoun
dandyoun
Reputation 90,550
#3 tenspeed
tenspeed
Reputation 73,340
View All