96 s10 runs rough, sometimes it'll run good but when you jump on the throttle it starts missing. When you ease off the gas it'll start running on all cylinders. I've changed both coil packs plugs and

Asked by May 31, 2015 at 05:00 PM

Question type: Maintenance & Repair

wires, fuel filter, checked the injector
wires and still same problem. Any
ideas

6 Answers

645

Hello, A situation you describe usually means spark breaking down under load, or lack of fuel FLOW... You have covered a bunch of the bases already. Has the fuel pump/sock ever been serviced/replaced in the tank? A garage that specialized in fuel injection would have a flow meter to check, but if you are handy, you can replace the items I mentioned above for nearly the cost of the Service. Good Luck, AskTrannyMan

1 out of 1 people think this is helpful.

I had the same problem, and it was my F150 rear tank pump and screen. Would drive ok easy but no power when I got on it. Rusty

So if I pull the fuel pump out I'll see the sock

645

Hello, Yes, 2 hoses on the tank at the neck, a couple at the sender, and then remove the lock ring...if you don't have/get the tool, you can carefully tap with a good, square end flat blade the ring counterclockwise to remove the sending unit w/fuel pump. Good Luck, AskTrannyMan

Should I just change the fuel pump or is the sock separate?

645

Hello, If am going to pull a fuel tank and have the coins, a new pump with the sock is going back in. Period. Hope this Helps, AskTrannyMan

Your Answer

Add photo

Related Questions

Shortcuts

Search Maintenance & Repair Questions

Maintenance & Repair Experts

#1 Tom Demyan
Tom Demyan
Reputation 150,590
#2 FordNut
FordNut
Reputation 103,360
#3 dandyoun
dandyoun
Reputation 84,340
View All