My 2006 Oldsmobile alero won't start but the battery is getting power, what could be wrong

Asked by Feb 04, 2015 at 12:27 PM

Question type: Maintenance & Repair

I  thought at first it could be the battery and realized the lights and sound works fine.

3 Answers

The lights and audio may well work fine with a weak battery, but not enough to start car. If your battery is original, it's time for a new one assuming you mean it won't crank over and try to start.

1 out of 1 people think this is helpful.

It not firing , want crank

Don't have an answer , asking

Your Answer

Add photo

Related Questions

  • Oldsmobile Alero ran hot now wont start no spark 3 answers

    About 3 weeks ago ran car hot for a while was out of town middle of no where trying to get to secure place. Now car will not Start turns over . But no spark please help can't afford another motor ...

    2001 Oldsmobile Alero GL Coupe

    -

    Maintenance & Repair

  • Whats wrong with my car?! 1 answer

    My 2002 Oldsmobile Alero died on the weekend, and I'm wondering if you can help me figure out why! I was taking a corner, and my abs/trac off/service engine soon lights came on. Then, my car comple...

    2002 Oldsmobile Alero

    -

    Maintenance & Repair

  • Alero Idle Issue

    Car: 2002 Alero with 2.2 Ecotech. Whats wrong? 3 months ago car was ran low on gas, stalled at an intersection. Got it home, oil was in the plugs. Replaced 4 plugs, boots, and gasket. Runs a little b...

    2002 Oldsmobile Alero

    -

    Maintenance & Repair

  • Car wont start and when try to start there is no humming sound 10 answers

    Put in a new fule pump and my car still wont start

    2001 Oldsmobile Alero

    -

    Maintenance & Repair

Shortcuts

Search Maintenance & Repair Questions

Maintenance & Repair Experts

#1 Tom Demyan
Tom Demyan
Reputation 165,810
#2 dandyoun
dandyoun
Reputation 90,500
#3 tenspeed
tenspeed
Reputation 73,330
View All