2003 F150 oil pressure problem need help!

Asked by Dec 29, 2014 at 09:37 AM

Question type: Maintenance & Repair

My truck randomly while I was
driving down the highway started
reading in the gage that there was
absolutely no oil pressure so I shut
off my truck and checked my oil to
make sure it had plenty in it and it
wasn't leaking any oil. Well it had
plenty of oil and it wasn't leaking, so
I turned my truck back on and kept
driving about 20 minutes later the
gage read no pressure again this
time I started to hear my truck knock
a bit I freaked out and shut it off
immediately, still checked the oil it
was fine. Any ideas on the problem?

1 Answer

5,365

It's either your oil pump or just a faulty pressure sending unit.

Your Answer

Add photo

Related Questions

  • 2003 F150 oil pressure problem need help! 1 answer

    My truck randomly while I was driving down the highway started reading in the gage that there was absolutely no oil pressure so I shut off my truck and checked my oil to make sure it had plenty i...

    Maintenance & Repair

  • Help! Low oil pressure. 5 answers

    97 Dodge ram 1500 Laramie alt 5.9l magnum. I have the same problem. Changed the pump, cleaned the pan, changed the sending unit. Nothing. I also hear what sounds like a lifter tap at and over 200...

    1997 Dodge Ram 1500

    -

    Maintenance & Repair

  • 2.9l oil pressure problem 2 answers

    Will driving my 2.9l B2 and when I came to a a stop I'll notice that oil pressure will completely drop out. Should I start with the oil sending unit or go ahead and replace the oil pump and pick up...

    1987 Ford Bronco II XL 4WD

    -

    Maintenance & Repair

  • Need help figuring out problem 1 answer

    So my 95 manual transmission chevy s10 started jerking back on me. I'm driving and seems to lose power or stalls on me. Can any one help me out here

    1995 Chevrolet S-10 2 Dr LS Extended Cab SB

    -

    Maintenance & Repair

  • I have a 2005 ford f150 with the 5.4 3 valve triton I had a problem with the oil pressure

    I replaced the cam phazers the timing chain guids and the oil pump but I am still having the same problem what else can it be what am I missing ???

    2005 Ford F-150 FX4 SuperCab 4WD

    -

    Maintenance & Repair

Shortcuts

Search Maintenance & Repair Questions

Maintenance & Repair Experts

#1 Tom Demyan
Tom Demyan
Reputation 174,370
#2 dandyoun
dandyoun
Reputation 93,400
#3 tennisshoes
tennisshoes
Reputation 75,810
View All

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.