I have a 86 gmc sierra classic. I replaced the coil but im still not getting any fire


Asked by Nov 29, 2014 at 06:36 PM

Question type: Maintenance & Repair

1 Answer


Have you checked the Ignition Control Module? http://www.doityourself.com/stry/how-to-test-an-ignition-module

Your Answer

Add photo

Related Questions

  • getting fire from coil but not to plugs 32 answers

    I have a 2000 dodge ram 1500 it died going down the road it is getting fire from the coil to the distributer but not to the plugs I have already replaced the distributer cap and rotor and still does ...

    2000 Dodge Ram 1500 4 Dr SLT 4WD Extended Cab SB


    Maintenance & Repair

  • no fire at the coils on my envoy 13 answers

    my envoy will not start from time to time I check and has no fire at coil packs, a hot 12 volts with ign on then all the sudden it gets fire and starts have replaced ign switch,map sensor,oilpressure ...

    2005 GMC Envoy XL Denali 4WD


    Maintenance & Repair

  • not getting fire from coil 3 answers

    Not getting fire from coil and I replaced the distributor cap rotor and plugs and plug wires and need ideas that would tell me why I am not getting fire from the coil

    1998 Dodge Ram 1500


    Maintenance & Repair

  • replaced coil pack but still cant get it to fire 4 answers

    turns over getting ful just not firing

    1986 Ford Crown Victoria LX


    Maintenance & Repair


Search Maintenance & Repair Questions

Maintenance & Repair Experts

#1 Tom Demyan
Tom Demyan
Reputation 146,270
#2 FordNut
Reputation 101,110
#3 dandyoun
Reputation 82,490
View All