I have a 1994 Nissan 300 ZX and as a slight miss and the codes coming up are 32 and 34 which is the EGR and the detonation sensor circuit

Asked by Jul 21, 2014 at 11:03 PM

Question type: Maintenance & Repair

It seems like if I had .spark plug wires
that they are Arking but it doesn't have
plug wires it almost seems like a bad coil
or a leaky injector it does it real bad when
I'm in 4th gear with a low rpm.does
anybody know what it might be or where I
should start looking to fix this miss in my
cylinder?I do you have a leak in my
plennum,so I need to replace those
gaskets other than that seems like maybe
a bad coil.it doesn't do it At idle except
sometimes it does but very slight so its
hard for me to pinpoint the exact cylinder
or problem from an idle.my TPS switch
wires were pretty corroded so I clean
them up and sometimes when I Nail it off
the line it's a little sluggish and
sometimes it takes off pretty good so can
anyone help me with this?its bugging me
pretty bad

1 Answer

34,165

On till you repair the leak it's going to be impossible to get it to run right.

Your Answer

Add photo

Related Questions

Shortcuts

Search Maintenance & Repair Questions

Maintenance & Repair Experts

#1 Tom Demyan
Tom Demyan
Reputation 171,780
#2 dandyoun
dandyoun
Reputation 92,570
#3 tenspeed
tenspeed
Reputation 74,710
View All

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.