hey guys having a problem keeping my temp down when pulling off to do a little 4 wheelin driving down the road its fine at 210 then off road it starts to slowly climb and never goes bacl down have elec fans hooked up has new radiater and new water pump new head and head gasket tried 3 diff thermostats and still getting same results even took out my a/c condensor to make breathing room for my other elec fan and still after 45 min of road time and straight spikes back up when pull off road does anyone know what else could make it run hott.help!!!

Asked by May 30, 2014 at 02:10 PM

Question type: Maintenance & Repair

guys having a problem keeping my temp down when pulling off to do a little 4 wheelin driving down the road its fine at 210 then off road it starts to slowly climb and never goes bacl down have elec fans hooked up has new radiater and new water pump new head and head gasket tried 3 diff thermostats and still getting same results even took out my a/c condensor to make breathing room for my other elec fan and still after 45 min of road time and straight spikes back up when pull off road does anyone know what else could make it run hott.help!!!

1 Answer

101,695

Are the fan shrouds still in place? Is thermostat properly installed or could it be upside down? Is cooling system completely full? Air in system can cause this.

Your Answer

Add photo

Shortcuts

Search Maintenance & Repair Questions

Maintenance & Repair Experts

#1 Tom Demyan
Tom Demyan
Reputation 150,400
#2 FordNut
FordNut
Reputation 103,270
#3 dandyoun
dandyoun
Reputation 84,280
View All