1996 5.7 yukon. loses spark after driving for a while then just dies and loses spark and two or three hours later it starts right up. replaced coil, checked icm, replaced coil wire. same issues

Asked by Feb 20, 2014 at 11:10 PM

Question type: Maintenance & Repair

1 Answer

9,055

Vortec engine -> You could also check the cam positon sensor in the distibutor. If it fails you will loose spark.

Your Answer

Add photo

Related Questions

  • no spark from ignition coil 27 answers

    not getting spark from ignition coil, replaced coil, still no spark

    1998 Jeep Grand Cherokee Laredo

    -

    Maintenance & Repair

  • No spark at the coil 15 answers

    1999 blazer s10 4.3 automatic losing spark. I found no spark at coil. I replaced crank sensor and ignition module and coil, spark plug and wires. I replaced the the distributor which includes cam sen...

    1999 Chevrolet Blazer

    -

    Maintenance & Repair

  • 1996 k1500 5.7 vortec...cranks but wont start 9 answers

    1996 gmc 1500. 312k on chassis and 120ish on motor and trans. was running perfect for 2500 miles since motor swap and then sat for 4 days. not cranks but wont start. it kind of just stumbles a time ...

    1996 GMC Sierra C/K 1500

    -

    Maintenance & Repair

  • 95 GMC suburban 5.7 won't start no spark, sputtered backfire ran fine died 4 answers

    95 Suburban sputters/loses power, backfires Loud, now won't start. I have a 1995 gmc suburban 5.7 350 v8 k1500, bought it in 2001 and ran perfectly fine with regular tune ups and maintenance , ne...

    1995 GMC Suburban K1500 4WD

    -

    Maintenance & Repair

Shortcuts

Search Maintenance & Repair Questions

Maintenance & Repair Experts

#1 Tom Demyan
Tom Demyan
Reputation 150,450
#2 FordNut
FordNut
Reputation 103,290
#3 dandyoun
dandyoun
Reputation 84,290
View All