I've got 87 camaro( my only ride) w/ 305 ,holley rebuilt carb....when I give it gas it pops and seems like its going to stop.the guys I'm trying to get it fixed with tell me its the holley.

20

Asked by Jan 16, 2014 at 08:01 PM

Question type: Maintenance & Repair

I also run 93 octane and put Lucas gas treatment, and octane
booster in it sometimes. just had value seals replaced. doesn't
burn oil .engine runs quiet no knocks. I know nothing about cars
and my income is limited, so I would be thankful for any advise
or opinions can't afford to get new car or new engine. Thx for
reading this.. mike

14 Answers

101,695

How long since last major tune up? (Plugs, plug wires, dist cap, ect). If it's been a while pull the dist cap off and make sure all the tits are clean. Also inspect other items- plugs,ect. Has it ran correctly since the valve stem seals where replaced? If not check that all the plug wires were installed in the correct order.

Best Answer
17,675

It could be the carb but it also could be a valve adjusted too tight when they did the valve seals or timing to low.

1 out of 1 people think this is helpful.
101,695

Good call tuff. That is also possible. Specially the valves and plug wire order with the seals being replaced.

101,695

Got to love these cars. This is my 85 z28

17,675

Exactly. Could be 2 spark plug wires crossed. 1-8-4-3-6-5-7-2 is the firing order.

20

I had the guy that replaced the seals and his partner clean the distributor, one guy worked for Chevy and there shop works on a lot of camaro.they build some neat cars... I've changed 6 plug wires myself and it seem to run better, can't get to the other 2.also they put new plugs in it. the car ran pretty well after the seals and cleaning the dist.,but we had a real cold spell here in bham and it wouldn't start at all till it got warm,then it started the popin when I gave it gas.it seem that when its cold or raining it doesn't run well.. it seems to run better when warmer. this guys also adjusted timing ThAnNK YOU A L L for you responces.

1 out of 1 people think this is helpful.
101,695

Sounds like spark jump. Bad plug wires and or old distr cap will cause spark jump when it's damp out. Next time it starts acting up open hood at night with no lights shining under there(must be perfectly dark under hood) and look for spark jump around the plug wires and dist cap. I feel you will find this to be part of your issue.

17,675

You also may have one or more spark plugs with cracked porcelain. Pull them out one at a time and look for hairline cracks or be able to turn the porcelain.

17,675

Or cracked dist. cap.

20

Thanks guys for our suggestions... can I go to an O'Reilly and get a new dist. cap. This poppin seems worse when I go up a hill....I haven't tried giving it a lot of gas since I changed some of the wires... but it cranks up really easily, cause I just went out and cranked it. I've looked at some of the plugs, they look OK..can't get to all of them and I don't have the right tools.(I was robbed 2 yes.ago and they took what tools I had) Would a new dist.be expensive.

1 out of 1 people think this is helpful.
101,695

Yes they should have them. And No not to expensive. Also replace the rotor button with the dist cap.

17,675

The ones you can't get to are more than likely the ones to be cracked. Yes, dist. cap & rotor button not expensive.

20

Thx again guys for the help....I'm going to say a prayer for you guys. reaching out to help others,like you guys are doing Is greatly appreciated.I'll let you know if I get it fixed. I'm supposed to see one of the guys tomorrow, if he's available. Mike

17,675

You should find your problem now we hope.

Your Answer

Add photo

Related Questions

Shortcuts

Search Maintenance & Repair Questions

Maintenance & Repair Experts

#1 Tom Demyan
Tom Demyan
Reputation 150,400
#2 FordNut
FordNut
Reputation 103,270
#3 dandyoun
dandyoun
Reputation 84,280
View All