turn signals not working

Asked by Oct 17, 2013 at 07:07 PM

Question type: Maintenance & Repair

Turn signals do not work when motor is running.  It will work with the ignition switch turn on, but not on running.  I changed the fuse, the light bulbs front and rear and I also changed the ignition switch.  Nothing has changed.

1 Answer

237,565

Maybe the issue is with the signal switch itself or the wiring.

Your Answer

Add photo

Related Questions

  • my turn signals are not working. 1 answer

    My hazards work and the interior signals blink, but the exterior signals dont flash.

    1973 Rolls-Royce Silver Shadow

    -

    Maintenance & Repair

  • turn signals don't work 3 answers

    turn signals don't work

    2001 Pontiac Grand Am GT

    -

    Maintenance & Repair

  • My turning signal not working 2 answers

    My turning signal not working you can hear it click but no lights ?

    2005 Chevrolet Impala Base

    -

    Maintenance & Repair

  • turn signals don't work 3 answers

    turn signals don't work, but hazards work and fuses are good help please

    1986 Ford Bronco II

    -

    Maintenance & Repair

Shortcuts

Search Maintenance & Repair Questions

Maintenance & Repair Experts

#1 Tom Demyan
Tom Demyan
Reputation 168,890
#2 dandyoun
dandyoun
Reputation 91,590
#3 tenspeed
tenspeed
Reputation 73,920
View All

Content submitted by Users is not endorsed by CarGurus, does not express the opinions of CarGurus, and should not be considered reviewed, screened, or approved by CarGurus. Please refer to CarGurus Terms of Use.